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Introduction

These courses are prepared to be followed using the version 15.0 of GiD. 
They are divided in GiD basic courses and GiD advanced courses. We strongly recommend to make the GiD basic courses before the 
advanced ones.

Installing GiD

On web page  you can find two types of GiD versions:www.gidhome.com

Official versions of GiD are stable versions of the program. They don't include the newest capabilities but they have passed all the 
validation tests.

Developer versions of GiD are more modern versions of the program that have new capabilities. Off coures new features can 
produce new bugs.

Choose from the installer link  or  or   bits, or  bits, depending on your operating system (OS). MS Windows Linux, 32 64 Mac OSX 64
Click on the option corresponding to your OS (Windows, Linux or Mac OSX), and then follow the instructions of GiD installer to install GiD 
into your computer. 

 A Windows x64 bits OS can run applications of x64 and x32 bitsNote:

Registering GiD

GiD can work with no licence (unregistered), but in this way the user can only manage a model with a few number of nodes (around 10000) 
and few surfaces. 
In case you want to try using a mesh with a higher number of nodes, a free password for one month can be downloaded from the web site 
(or a permanent one buying a licence)

Password for GiD: http://www.gidhome.com/pricing/passwords

Installing Problemtypes

Following GiD terminology, a  is a calculation module able to perform a simulation and which customizes GiD so as the user 'problem type'
can apply to the model the material properties, boundary conditions and other information needed for the simulation process. 
After the GiD installation process, it is needed to add the required  To do it, usually is only needed to copy the problemtype 'problem types'.
folder inside the /problemtypes gid folder. 
It is possible to manually copy these problemtypes or dowload them from Internet.

If you have internet connection, start GiD and go to menu: . A window with the available Data->Problem type->Internet retrieve
problem type modules will appear, splitted in the different operating systems and platforms.

There is a mark on the currently installed problemtypes. 
To get some new ones, select them and click "Retrieve module" to install them. 
Once the problemtype has been downloaded, close the window and you can check it is present in the list of problem types installed in the Da

 menu.ta->Problem types

http://www.gidhome.com/purchase/passwords
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NOTE: The basic course requires for the 'Run a CFD simulation' chapter to install the Kratos problemtype. Kratos problemtype does not 
require any specific password.

Material location

The PDF documents and most of the models of the basic and advanced courses can be found at www.gidhome.com/archive
. /GiD_Documentation/Courses

https://www.gidhome.com/archive/GiD_Documentation/Courses
https://www.gidhome.com/archive/GiD_Documentation/Courses
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GiD basic courses
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Basic GiD management

The objective of this course is to get   GiD: how to change the views of the model, how to manage the layers, and other basic familiarized with
features. Some of these features are both in the preprocessing and the postprocessing modes of GiD, although the examples shown are 
from the preprocessing one. 
Many times the text will make reference to  Almost all the options explained in this course are valid both for geometrical and mesh 'entities'.
entities, although the examples used are often geometrical ones.

User interface

Starting GiD

When GiD is started for the first time a pop-up appears where you can choose OpenGL working mode and GiD theme.
If you are confident with your graphic card please choose . With this mode the model will be drawn quicker, so you Fast visualization mode
will feel a better interaction with the model. Nevertheless, some issues could appear depending on your graphic card and its drivers. 
These courses have been done with the  The theme only affects the GUI appearance, so there is no problem to follow the  GiD black theme.
course with another theme. 

These two options can be changed later in the preferences window (select ).Utilities->Preferences

CHANGE OPENGL OPTION

This option is managed inside  branch.UtilitiesPreferences... Graphical->System

Also it's possible to change it by clicking on  /   in the bottom right corner of GiD window.

CHANGE THEME

User can choose between Classic and Black themes, which change drastically the GUI appearance. User can also choose between some 
icon sizes in each theme.
These options can be changed in  option inside  branch.GiD Theme UtilitiesPreferences... Graphical->Appearance
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Preprocessing and Postprocessing modes

GiD basically works in two modes: preprocessing and postprocessing. 

To change between both modes please select  or  (or clicking  /  in the main Files->Postprocess Files->Preprocess
toolbar).

Warnline

In some of the operations made in GiD, GiD gives information about what is expected to do by the user. This information is very useful the 
first times GiD is used as a guideline for the user.
The place were this kind of information is shown is the lower part of its main window.

Command line

Using GiD, sometimes the user is asked to introduce data with the keyboard. The 'Command line' must be used for this purpose. It is placed 
in the lower part of GiD window.

Status bar

The Status & Information bar located at lower part of GiD's Window, provides basic information at a quick glance.

From left to right you can find:

Zoom factor

Current number of nodes and elements (Click to acces to Status Window)
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Current renter mode (Click to change render)

Number of layers in Pre, number of sets in Post

Mouse coordinates (Click to open "Coordinate window" in Pre and "Change result units" in Post)

Current Mode: Pre or Post

Mouse menu

Clicking the right mouse button on the main graphical window opens an on-screen menu with some visualization options. To select one of 
them, use the left or right mouse button; to quit, left-click anywhere outside the menu. 
The first option in this menu is called . You can select from different options relevant to the function currently being used, e.g. Contextual
when asking for a point they appear options like "Point in line", to select a point over a line, or "Arc center" to select the coordinates of the 
center of an arc.

Zoom, Rotate, Pan, Redraw and  are the same options as in pre and postprocess mode.Render

Label in preprocess shows a label with the current entity number, depending if we are in preprocess, geometry and mesh, or in 
postprocess.

Layer/Mesh (depending if we are in pre or postprocess mode) menu lets user to switch on/off layers.

Switch full screen changes GiD main window to full screen mode.

Image to clipboard creates an image fo the current visualization and placed in the clipboard.

Escape function

An important thing a GiD user should know as a general philosophy of use of the program is the  key functionality: in almost all the Escape
actions performed by the user, to declare the action as done the user should press  key (or press the center mouse button).Escape

Change views of the model
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1.  

2.  

3.  

In the  menu user can find the options to change the point of view in which the model is shown. Many of these options are also View
accessible by the right mouse button menu, or the icons toolbar.

Zoom

To zoom in or out the model user can choose the corresponding options in the  section of the  menu or the right mouse button Zoom View
menu. 
A user friendly way of zooming the model is to use the wheel of the mouse, or clicking the center button of the mouse while the  key is Shift
pressed.
To get a view which includes the whole model the  option must be selected. Frame
The icons corresponding the zoom operations are the following ones:

Zoom in:    

Zoom out: 

Zoom frame: 

Pan

To move the view of the model user must select the option . This option is accessible from the  menu, the right mouse button menu, Pan View
or moving the mouse while the  key and the  are pressed.Shift right mouse button

The corresponding icon for the pan option is the following one: 

Rotate

In  menu (also present in the right mouse button menu) there are the options to rotate the view of the model.View->Rotate
A user friendly way of rotating is to move the mouse while its  and the  key are pressed.left button Shift

The corresponding icon for rotating the model is the following one: 

Set center of rotation

An interesting option for rotating the view of the model is to set the center of rotation. To change it:

Select  from top menu or  from right button mouse menu. Then, the cursor changes into the View->Rotate->Center Rotate->Center
selection mode.

Select an existing point of the model.

Now rotate the model and check that the center of the rotation is the one selected.

View management

There are several pre-loaded views in order to align the object axes with the screen axes. These views can also be selected clicking on 
 icon.

When we are working it's possible to change to previous views using     icons.
It's also possible to save in a file an specific view to use it later in order to take some snapshots of our model. In order to do that select View-

. and to read it just select >View->Save.. View->View->Read...
This option is useful to get the same perspective of the same model when we work on different sessions.

Render modes

In the  menu user can find the  options. They are also accessible from the right mouse button and the status bar.View Render

Select View->Render->Normal

Select View->Render->Flat

Select View->Render->Smooth

In  render mode, user can see the entities drawn in different colors, depending on the kind of entity: volumes in light blue, surfaces in Normal
pink, lines in blue, and points in black.

 render mode draws each geometrical entity using the color of the layer it belongs to, and  mode uses also this criterion, but Flat Smooth
lines are not drawn to represent the geometry in a smoother way. The following figure shows the visualization of the model changing render 
modes:
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1.  

2.  

3.  

4.  

1.  

2.  

3.  

4.  

 

Render normal

 

Creating images

We can take snapshots of our model. You can save images in several formats. The properties of the image (resolution, size, etc.) can be 
assigned in Page and capture settings option.

Select Files->Page and capture settings...

Check the  option in order to cut the image in the model limitsAuto crop image

Click on  buttonSet Page

Click on  buttonClose

In order to save the image with the defined properties in Page and capture settings:

Select  and the desired image format throught the menu barFiles->Print to file

Choose the location where you want to save the image

Choose a name for the file

Click on  buttonSave
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1.  

1.  

1.  

2.  

NOTE: This action could also be done by clicking on   through the icon bar. This icon can also be found in the "Page and capture 
settings" window. In this case the image format is choosen while saving the file in the "Files of type" combobox.

Preprocessing mode

Load a model

In the  menu user can find the typical operations for managing the GiD projects like save a project, open an existing project, import and Files
export files, print or quit the program. Most of this options are also accessible from the icons toolbar. The corresponding icon is shown in the 
menu, next to the option.

Click on  and select the GiD model . GiD also can load a model just with .Files->Open... gid_model_basic_course.gid drag & drop
The following model should be loaded:

Geometry and Mesh modes

In the preprocessing part of GiD there are two basic modes the user can work with: geometry and mesh. Just in order to see how the mode 
can be changed we are going to generate a mesh with all the default parameters.

Select  The following window should appear.Mesh->Generate mesh...

Click OK and wait for the mesh generation. Once the mesh is generated, a window pops up and show the user the result from the 
mesh generation.

Click on 'View mesh' option, and the following visualization of the model should appear:



GiD

12Copyright © 2020, GiD, CIMNE 

1.  

2.  

3.  

Now we are in 'mesh' mode. Changing the render mode user can see that the color of the mesh entities also follows the Layer colors.

Selecting  user can change to the geometry mode again. The   icon in the toolbar switch between both modes.View->Mode->Geometry

Entities information

Labels

Using the option  present in the  menu (and also in the right mouse button menu), user can see the number of the entities of the Labels View
model. Either for points, lines, surfaces or volumes user can choose between viewing the numbers of all the entities, or just the selected 
ones. 
In the following figure the model can be seen with the number of some entities:

List entities

User have also the option of viewing all the characteristics of a specific entity by selecting  in the  menu (or clicking  in the List Utilities
icons toolbar).
For example:

Select  in the top menuUtilities->List->Surfaces

Select some surfaces of the model

Press Escape

An example of the information got using this option is the following figure:
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1.  

2.  

Signal

In complex geometrical models sometimes it is hard to localize an specific entity. Using the  option in the  menu user can Signal Utilities
know graphically where the entity is, as GiD shows with a red lines cross its position. This option is also present in postprocessing mode. 
As an example we will signal the line number 290:

. Selec Utilities->Signal->Lines

. Write in the Command bar the number 290 and press ENTER. The result is shown in the next figure:

The red lines are centered always onto the specific entity independently on the rotations or view movements.

Layers and groups

A really useful way for organizing the different parts of the model is using 'Layers'. 

Open the Layers window by selecting the  option or clicking   in the upper icons toolbar. The following Utilities->Layer and groups
window should raise up:
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1.  

2.  

1.  

As it can be read in the upper part of the window, if user double click on that part, the Layers window is integrated in GiD window. User can 
choose to work with the Layers and groups window integrated or not inside the main GiD window. 
All the actions related with layers and groups can be accessed by clicking the right mouse button onto the Layers and groups window. Most 
of them can be also used by the corresponding icon in the upper part of the Layers window.
By moving the mouse over the icons of the upper part of the window and staying 2 seconds onto an icon, a help message is shown in order 
to give the user information about the action associated with the icon.

Create a layer

GiD allows a hierarchical structure of Layers, so as a Layer can contain sub-layers. Let's create a Layer into another one as an example:

Select (using the left button of the mouse) the 'Layer6'.

Select the  option in the right mouse button menu, or click   in the upper part of the Layers and groups window. New child
Automatically, a layer named 'Layer0' should appear, as shown in the following figure:

Rename a layer

To rename a Layer user should select the layer in the Layers and groups window and press  key, or select the  option in the right F2 Rename
mouse button menu.
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1.  

2.  

1.  

2.  

3.  

1.  

Select the Layer0

Rename it to 'Auxiliar'

Now the Layers window should look like the following picture:

Change the color of a layer

By clicking on the colored square next to each layer name, the following window pops-up, allowing the user to change the color of the layer:

Send entities to a layer

User can send entities to a specific layer. As an example we are going to send to the layer 'Auxiliar' a part of the model:

Select the layer 'Auxiliar' in the Layers window

Select the option  from the right mouse button (or click   icon)Send to

Select  and select the volume shown in red in the following figure:All
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1.  

2.  

Then press  to exit the selection mode.Escape

Set the render mode to . The color of selected volume has changed to the one of the layer 'Auxiliar', as shown in the following Flat
figure:

Switch on/off

By clicking on the   icon which is next to each Layer inside the Layers and groups window, user can switch on and off the corresponding 
layer. This is very useful in order to visualize just some specific parts of the model.

Freeze a layer

At the right side of the bulb, user can set an icon which is a lock  . If the lock is closed  , the layer is frozen. If a layer is frozen, GiD 
won't apply anything to the entities of that layer. For instance, if user select some entities to be deleted, if they are into a frozen layer they 
won't be erased.

Transparency

Next to the 'lock' icon of each layer is the transparency icon  . By clicking there, the user can set a layer to be transparent or not. The 
following figure shows the model with the Layer11 set as transparent:

Postprocessing mode

Load results

There are two ways to load the results simulation information into GiD:
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1.  

1.  

2.  

3.  

1.  

If the model has been calculated inside GiD, and so the results are inside a GiD project, then just loading the GiD project and the 

changing to postprocess mode is enough. This can be achieved clicking on this icon:  , or selecting the Files-
 menu entry.>Postprocess

If only a mesh and results file(s) is present then GiD should be started, and switched to postprocess mode before loading the file(s).

In this case we will use the first option.

Switch to postprocess mode:  or Files->Postprocess

Entities information

LABELS

Using the option  present in the  menu (and also in the right mouse button menu), user can see the number of the entities of the Label View
model. Either for nodes, elements or results user can choose between viewing the numbers of all the entities, or just the selected ones.

LIST ENTITIES

User have also the option of viewing all the characteristics of a specific entity by selecting  in the  menu (or clicking  in the List Utilities
icons toolbar).
For example:

Select  in the top menuUtilities->List->Nodes

Select some nodes of the model

Press Escape

An example of the information got using this option is the following figure:

Select and display style

Through the  window several options can be specified for the different sets (containing volumes, surfaces or cuts). Select & Display Style
Among these options, sets can be switched on and off, their color properties can be changed, and their transparency too.
Other interesting options which can be changed are the style of the set and the width of the elements' edges.
From this window, volumes, surfaces or cuts can be deleted or their names can be modified.
The Select & Display Style window can be integrated inside GiD interface, just double click on the upper bar of the window. To tear it off 
again, double click the upper bar again.

Select  using the menu bar or clicking on Window->View style...
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1.  

2.  

Rename a layer

To rename a layer user should select the layer in the Select and display window and press  key, or press the  button.F2 Rename

Select the Layer6

Rename it to Aux

Now the Layers window should look like the following picture:

Change the color of a layer
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1.  

2.  

3.  

4.  

5.  

By clicking on the colored square next to each layer name, the following window pops-up, allowing the user to change the color of the layer:

Send entities to a layer

User can send entities to a specific layer. As an example we are going to send to the layer 'Test' a part of the model: 
Our model only has 2 layer. We will create a new layer with some elements.

Press button , and select Send to New set

Select some elements

Press Escape

A window appears asking for a name. Enter 'Test'

Press Accept

A new layer is created with the selected elements. Now we can change the color of the new layer.
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1.  

2.  

Switch on/off

By clicking on the icon which is next to each layer inside the Select and display window, user can switch on and off the corresponding 
layer. This is very useful in order to visualize just some specific parts of the model.

Style and transparency

By selecting one set and clicking on one corresponding style icon at the  column or clicking on  , the style for the selected mesh is St
changed. Bear in mind that a boundary visualization of the surface of a sphere nothing will be visualized, as a sphere surface has no sharp 
borders.

Mesh styles can also be changed clicking on the icon  , placed in the left icon bar. This style affects all sets of the model.

Next to the style icon of each layer is the transparency icon  . By clicking there, the user can set a layer to be transparent or not.

Select Layer11 and change the style to Body

Set it to transparent

The model should look like this:
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Geometry creation and edition

Description

This tutorial is focused in the use of the basic geometric tools of GiD.
We will explain how to create a CAD model of the Egyptian construction shown in the figure below.

Egyptian funerary complex perspective

Some simplifications of the geometry are allowed. In the following parts of the course some schemes describe the dimensions of the 
simplified shape of the model. 
We want to create a volume of a portion of the air around a control volume. We use a 300x200x100 m box so that the faces of the box are 
relatively distant from the temple (the creation of this model is suposed to be used for a CFD simulation analysis of the airflow around the 
building).

Simplified model

In this section we will use the GiD facilities (creation of lines, surfaces, copy tool, use of layers, etc.) to create the geometry of the Egyptian 
construction shown following scheme (dimensions are in meters). The width of all the walls is 2 meters. 
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Plant scheme 

Profile scheme

Of course, there is not a single way to build this shape. We will use several tools in this course which may not be the optimal ones, 
considering that the objective is to show as more tools as possible for the geometry creation using GiD.

NOTE: Not all dimensions are specified in the scheme, the undetermined ones should be approximated based on the images.

Points and lines creation

We will start creating the wall lines located the ground (plane z=0) 
To facilitate visualization and selection tasks we will separate entities in several layers with this tree structure:
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Final layers structure.

We will start creating the lines of the plant, in the z=0 plane. 
Be sure the layer in use is the 'walls' one. The layer in use is marked with a 'check' between the name and the color of the layer. To set the 
'walls' layer as the layer in use just double click onto the name of the layer. 
New entities will be created in the current 'layer to use'.

Line creation

Choose the  option, by going to  or by going to the GiD Toolbox (the GiD Toolbar is a Line Geometry->Create->Straight line
window containing the icons for the most frequently executed operations. For information on a particular tool, click on the 
corresponding icon with the right mouse button).

Enter the coordinates of the beginning and end points of the auxiliary line. The coordinates of a point may be entered on the comma
 either with a space or a comma between them (but not both). If the Z coordinate is not entered, it is considered 0 by default. nd line

After entering the coordinates of one point, press . Another option for entering a point is using the , Return Coordinates Window
found in ...Utilities->Tools->Coordinates window

For our example our coordinated origin will be set at the lower-left of the bounding box of the building, and we will create the lower line that 
starts at x=10 and ends at x=10+35=45 units, the coordinates are then (10,0) and (45,0) respectively. Besides creating a straight line, this 
operation implies creating the end points of the line.
Write then:

10,0<Return>

45,0<Return>

Press  twice to indicate that the process of creating the line is finished. (Pressing the  key is equivalent to pressing the <Esc> <Esc>
center mouse button).

If the entire line does not appear on the screen, use the  option, which is located in the GiD Toolbar and in  Zoom Frame Zoom
option in the mouse menu.

Creating a straight line

NOTE: When creating a line, after clicking the first point, you can press the  key to snap the dynamic line to the screen horizontal, vertical Alt
or 45º diagonals. 

: The  option, located in , enables you to undo the most recent operations. When this option is selected, a NOTE Undo Utilities->Undo
window appears in which all the operations to be undone can be selected.

Join NoJoin option

When generating geometry, very often it is needed to select some point: a new one (like the ones that have been defined in the previous 
steps for defining the lines), or an existing one. When an already existing point is wanted to be selected, user must go to Contextual->Join 

 in the mouse menu (right-click), or pressing . Ctrl-a <Ctrl>+a
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Contextual menu when expecting a point

The pointer will become a square, which means that you may click an existing point. User can change alternatively between both modes 
(clicking an existing point or a new one) in the same selection process.

Choose the  option, by going to  or by going to the GiD Toolbar.Line Geometry->Create->Straight line

Press  to select an existing point (ensure the mouse pointer is square-like)<Ctrl>+a

Click on the point on the left.

Press  again to select now new points (ensure the mouse pointer is now a cross)<Ctrl>+a

Then enter the following points by coordinates (like in the previous steps):
10,33

0,33

Press  twice to indicate that the process of creating lines is finished.<Esc>

Now the model should look like the figure.

State of the model geometry at this point.

Relative coordinates

In GiD there are two ways of defining the coordinates of a point: absolutely (like all the coordinates we have entered since now in this 
course) or relatively to the last point entered (using @ symbol). We will now enter a point using this second option, which is very useful when 
points wants to be entered knowing some distance.

Choose the  option, by going to  or by going to the GiD Toolbar.Line Geometry->Create->Straight line

Press  to select an existing point (ensure the mouse pointer is square-like), and select the point which is more at the left in <Ctrl>+a
the model.

Press  to select a new point (ensure the mouse pointer is a cross).<Ctrl>+a

Enter the following relative coordinates: (@0,72)

Press  two times to leave the line creation mode.<Esc>
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Line created with a length of 72 meters, entered as a relative coordinate to its second point.

As it can be appreciated, the new point has been created at 16 meters (as the relative coordinates indicated) of distance from the first 
selected.

Copy tool

Another useful option for creation of geometry is using the different geometrical transformations GiD offer in the  and  windows. Copy Move
Now we are going to copy the upper point translated 55 m in x direction, and creating a line between the source and destination point by 
extrussion.

Use the  window, which is located in  (you can access that window also using the  icon from the Toolbar, Copy Utilities->Copy
or the keys <Ctrl-Shift-C>).

Within the  menu and from among the  possibilities, select . The type of entity to receive the Copy Transformation Translation
translation is a line, so from the  menu, choose .Entities type Points

We want to make a translation of 55 units in the x direction, so we should leave the coordinates of the  at (0,0,0), and set First Point
the coordinates of the  at (55,0,0) (the translation is defined with the relative vector from the first to the second point)Second point

Do extrude: set to Lines

The following options of the window should be the same as the ones in the figure.
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Copy options to be used.

Click on Select and select the point to be copied (the upper-left point)

Press  to exit the selection mode.<Esc>

You would get the model like the one shown in next figure.

State of the model at this point.

With the copy tool we can create the lines on the right with a copy by symmetry, around an axis on x=27.5.
Set  to be selected as ,  as Entities type Lines Transformation Mirror
Check  to define the symmetry only with two points on the axis (instead of the 3D case that require three points on the Two dimensions
symmetry plane)
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Set two axis points, like (27.5, 0.0, 0.0) and (27.5, 1.0, 0.0),    and check that  is marked Do extrude: No Collapse
and select the three red lines to be copied.

Copy lines by symmetry.

Finally create another line to split the shape in two rectangles

Offset

The walls have a width of 2 meters, now we will build the inner perimeter using the  tool with  Copy 'Offset'.
And now we will orient all curves of the upper rectangle coherently (e.g. all clockwise or all counter-clockwise), to be able to do a copy by 
offset. 
use: Utilities->Swap normals->Lines->Select
And select all lines, then are drawn an arrow in cyan, representing the curve tangent, and a pink arrow representing the normal (defined for 
2D planar curves only, rotating tangent 90 degrees to the left, around the z axis).
Click the lines to be swapped to point all pink arrows inside the upper rectangle
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The offset factor is positive pointing to the line normals direction, or negative in the opposite one. When selecting the lines to be copied we 
see its orientation. We can cancel the copy deselecting all before finish (can do it with " " of the contextual menu) Clear selection
Repeat the operation for the lower rectangle, obtaining this result

Inner perimeter created by two offsets.

Intersection

To create the square of the pyramid we know the distances to the boundary, we can use the copy by translation to create some auxiliary 
lines, and then intersect them with
Geometry->Edit->Intersection->Lines

And then delete the unwanted lines.
Geometry->Delete->Lines
then in the contextual menu (right-mouse button) select to delete also the points that become isolated after the deletion.Lower Entities 
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Finalize the lines creation

Now you should complete the remaining geometry until obtaining a figure similar to the one shown below. Use the explained geometrical 
operations to complete by you own the geometrical definition of it. 
It may be useful for you to use some other geometrical operations, like the ones present in Geometry menu. They are easy to use, and its 
names are intended to be self-explicative, we encourage you to try some of them for the creation of the geometry (e.g. division, intersection 
of lines, deletion, collapse of points, etc.)

A new tool will be need to obtain final result, if there are two lines connecting tangent, you can use  to obtain Geometry->Edit->Join->Lines
an unique line without middle point

Current state of the model.

Take care of all lines of the model, check that the walls are totally connected without any division.

Surface creation

In the following sections we are going to complete the geometrical model definition using different surface creation techniques.

Extrusion of walls

For creating the walls we will use the translation tool inside  window for the extrusion of the lateral surfaces, and then create the top Copy
surfaces.

First of all let's use the  function (  from the mouse right button menu, or clicking the corresponding icon  ) to Rotate Rotate->Trackball
see the lines of the model from a different point of view, which will help us to understand the model. 
Ensure the active layer is the one named 'walls' and follow the next steps:

Open the  window, which is located in  (you can access that window also using the  icon from the Copy Utilities->Copy
Toolbar).

We are going to apply a translation of 5 units in z direction to all the lines except the ones of the square defining the base of the 
pyramid. For this purpose ensure all the options of the window are like the ones shown in the figure.
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Options to be applied

Select the lines of shown in left figure and click on  button. The result should be like shown in the figure on the right.Finish

Take care on the different visualization modes that can be used for visualizing the geometry. This options are ,  and Normal Flat Smo
, and can be selected from the  option in the mouse right button menu. oth Render

: in Flat render mode surfaces are painted with the layer color. Don't worry if you are seeing different colors, layer colors could Note
be changed.

Creation of top of walls
Now we have created the lateral surfaces of the walls, and we must create the top surface. 
We have all the contour lines of the surfaces to be created, so we have several options of creating them. The simplest one is to 
select  (or clicking the corresponding icon), and select all the contour lines Geometry->Create->NURBS surface->By contour
which define the contour of the surface. 
We need to select as boundary all curves on z=5, an easy way to select them is to set an appropiated view, like Rotate->Plane XZ
then select with a box all upper lines, and unselect with another box the unwanted vertical curves.
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The lines to select to create the top planar surface

Creation of the pyramid

We are going to create the pyramid in the layer named 'pyramid', so you have to set this layer as the one in use. 
For creating the pyramid, first of all we need to create the vertex of it, and need to calculate its coordinates. You know that the total height of 
the pyramid is 30 meters, but you don't know the x,y coordinates of the projection on the ground. You can calculate it as the midpoint 
between two diagonal points.
Open the calculator with 
Utilities->Tools->Calculator...

 

Calculator window after select two diagonal corners.

Select the  and click a corner of a diagonal (top More...->Get point
left) 
their coordinates will appear in the calculator 
8.0,98.0,0.0 
Repeat it and now get the opposite diagonal corner. 
47.0,59.0,0.0 
now to calculate the sum pressing button  +
now to divide by 2 enter this number pressing the buttons 

 2 Ent
and pres the button 
 /

the vector result is shown 
27.5,78.5,0.0 
to send this value to the GiD comand line press 
More...>Write

Select  and modify in the command line the coordinates changing z=0 to z=30, to obtain: 27.5,78.5,30.0 Geometry->Create->Point
and press enter to create the point with this coordinates 

Note that the points can only be seen in  (not in  or  mode).Render Normal Flat Smooth

Then create one straight line from each vertex of the quadrilateral base of the pyramid to the vertex of the pyramid.

For creating the lateral surfaces of the pyramid:

Select  (or click the corresponding icon), select the three lines of one face of Geometry->Create->NURBS surface->By contour
the pyramid and press .<Esc>
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Manual creation of a surface of the pyramid

For simple geometry configurations, GiD can detect the contour lines of a possible surface automatically. We will use this option. 
Select again . But now click on the right mouse button and select  in the Geometry->Create->NURBS surface->By contour Search

Contextual menu.
Then click once for example the lines of the base of the pyramid (a line of the desired surface)

As you can see, each time you click a line, GiD find automatically the other lines which close a surface parting from the selected line.

Creation of ground surface

We should define the limits of the domain into where the simulation will be done. This limits should be far enough from the model to avoid 
the effect of the boundary conditions in the results.
We are going to create now the surface of the ground of 200x300 m.

Set the 'ground_outer' layer as the one in use.

Create a rectangular surface: Geometry->Create->Object->Rectangle

with a corner at (-70,-100,0) and the opposite corner at relative coordinates (@200,300,0). Then, we will add a hole to this surface using
Geometry->Edit->Hole surface->With lines
then select the surface to be holed and then select the trimming lines

The rectangle holed

Then Set the 'ground_inner' layer as the one in use and create the other missing surfaces of the ground.
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Creation of the 'ground_inner' surfaces

You should obtain the following geometry, seen from below in the figure:

Creation of control volume surfaces

For creating the outer surfaces of the control volume we will use again the  tool of the  window.Translation Copy

Set the 'air//surfaces' layer as the one in use.

Open the  window, which is located in , and set all the values of the parameters as the ones shown in the Copy Utilities->Copy
following figure. Note that the 'Maintain layers' checkbutton is unset, to create the new entities in the current layer to use instead of 
the layer of its source entity.
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Parameters to be used for the extrusion of the outer lines of ground surface.

Select the 4 outer lines of the ground surface and press Finish.

Now the lateral surfaces of the control volume have been created.

Create the top surface of the control volume by its boundary lines, and the model should be like the one shown in the figure.

State of the model creation at this point.

Note that you can apply transparency to one Layer by clicking in the icon placed on the right part of the corresponding layer in the Layer 
Window.

 Volume creation

Due to the hierarchical definition of the geometry inside GiD, a volume requires to have a closed path of surfaces as contour. For checking 
that a path of surfaces is water-tight (closed), GiD offers one graphical tool ( ) which is very useful.Higher entities
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Click on . You should obtain the information of how many surfaces own each line. In this case all the View->Higher entities->Lines
values should be 2, like is shown in next figure.

Higher entities of the lines of the model.

Press  to return to the normal render mode. The last step for the geometry creation of this model is create the volume:<Esc>

Select  and select all the surfaces of the model except the upper rectangle (simulating Geometry->Create->Volume->By contour
an user selection error).

Then a window like this is shown (the number of entities could be different depending on the way of create the geometry).

Lines of the surface missing to close a volume

The meaning of this 'ugly message' is that the volume is not closing topologically in the printed entities. You can use copy/paste of the last 
list of line ids "125 126 127 128" to set on its labels and identify visually the problem.

and you will see that just are the lines of the missing surface.View->Label->Selected->Lines  125 126 127 128  

Repeat the creation of the volume, but now seelction all surfaces, then press , and the volume should be created. Note that the ESC
volume (using GiD Normal render mode) is represented by a light blue line following the contour lines.

Now the geometrical model is finished, and it should look like the one presented in the figure.

Geometrical model finished.
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Save this gid project with  with the name 'Pyramid_geometry' Files->Save as..
It is recommended to try to generate a coarse mesh to be sure that all is ok and they are not geometric problems for a future simulation.
E.g. use  with a general meshing size=20 m, you must obtain a mesh with only tetrahedra elements.Mesh->Generate mesh...
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Meshing basic features

This course is focused in the basic meshing features and cappabilities of GiD. 
To follow this course, the models   and  must be loaded from the gid_model_basic_meshing_course.gid gid_embedded_example.gid
folder where the courses material is.

View of the model used for most of the parts of this course View of the model used for the embedded mesh part of the 
course

In this course the three basic mesh types supported by GiD are shown:

Body-fitted: this mesh type corresponds to a body-fitted Finite Elements-like mesh. The mesh is fitted to the contours of the 
geometrical entities.

Embedded: This mesh type corresponds to an embedded mesh (not fitted to the contours of the embedded closed region). This 
kind of models have one or more geometrical volumes (the calculation volumes) and an embedded closed region. The calculation 
volumes are meshed in a body-fitted way, and its nodes have the extra information of (signed) distance to the contours of the 
embedded region.

Cartesian: This mesh type corresponds to a Finite Differences-like mesh, a cartesian grid aligned to XYZ axes.

Default meshing settings

For this section we need to load the model gid_model_basic_meshing_course.gid

First of all we should reset all the meshing preferences in order to ensure the meshing options got from GiD are the same as the ones 
needed to reproduce exactly this course. For this purpose:

Open the preferences window (Utilities->Preferences)

Set the 'Meshing' branch.

Shift+select last child of the branch: "Other".

After selecting all meshing childs right click and select "Default values on selection".

If some value has changed (it would be highlighted in red) you will need to Apply changes by clicking on "Apply" button.
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If user does not assign any meshing property to the model, GiD generates body-fitted meshes and it assigns an automatic mesh size based 
on the size of the model. Elements by default are triangles (for surfaces) and tetrahedra (for volumes) and the mesh is unstructured. Let's 
have a look at this first automatic mesh.

Select the option 'Generate mesh...' from the 'Mesh' menu.

A window will appear asking for the mesh size to be used. For this model, the value proposed by GiD by default is 1. In this window 
the option 'Get meshing parameters from model' also appears. If this option is set, GiD loads the meshing parameters used the last 
time the model was meshed. Now unset this option, and click OK.

A window will pop up giving the basic information of the result mesh (number of nodes and elements, memory consumed, etc.). 
Click on 'View mesh' and the following mesh should be shown:

Mesh resulting using default options

Quadratic type

User can choose between different quadratic element types by selecting the 'Quadratic type' option in the 'Mesh' menu.

'Normal' option corresponds to the linear elements.

'Quadratic' option corresponds to the linear element with quadratic nodes in the middle of its edges.

'Quadratic9' option is like the Quadratic one, but with quadratic nodes also in the center of the faces of the element, and the center 
of the element. This quadratic type is only applied to quadrilateral, hexahedra or prism elements.

Let's make a quadratic mesh of the model.

Select 'Quadratic' as the quadratic type in the mesh menu.

Then generate the mesh again. The resultant mesh should look like the previous one, but if we zoom in at some area and we label 
all the nodes we should see that the elements are quadratic:
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Detail of the mesh of a surface of the model, where all the nodes are labeled, so the quadratic nodes can be seen.

Types of body-fitted mesh

Different kinds of body-fitted meshes can be generated using GiD, depending on the topology required: unstructured, structured and semi-
structured. 
Set as 'Normal' the Quadratic type of the mesh (from Mesh menu) in order to reach the same meshes as the shown in this chapter.

Unstructured mesh

ASSIGN SIZES

As said in previous steps, the default mesh generated by GiD is a unstructured mesh, and a general size is set to the whole model. 
However, it is possible to refine specific regions of the model by assigning different sizes to the geometrical entities. Let's see it in an 
example where the entities labeled in the following figure will have different size assigned.

Entities to be selected in the following steps to assign mesh size.

Select the 'Unstructured->Assign sizes on surfaces' in the 'Mesh' menu, and set 0.2 in the appearing window.

Click on Assign and assign the surface number 10. Then press ESCAPE to finish the selection, and close the size window.

Select the 'Unstructured->Assign sizes on points' in the 'Mesh' menu and set 0.05 to the point number 22. Then press ESCAPE to 
finish the selection, and close the size window.

Generate the mesh again (Mesh->Generate mesh), and the following mesh should appear.
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Result mesh of the model once some specific sizes have been assigned.

SIZE TRANSITION FACTOR

When different unstructured mesh sizes are present in the model, a transition between them is applied in the unstructured mesh. User can 
control whether this transition is smoother or sharper by the 'Unstructured size transitions factor'. This option is in the 'Meshing' branch of 
'Preferences' window (Utilities->Preferences).

Open the preferences window (in the 'Utilities' menu) and set the 'Unstructured size transitions factor' to 0.2 (this options is in the 
Meshing->General branch). Click 'Apply' and close the preferences window. Then generate the mesh again (Mesh->Generate 
mesh).

Repeat the operation setting the 'Unstructured size transitions factor' to 0.9 to see the difference between the resultant meshes. 
Those meshes are shown in the next figure.

 
Mesh using 0.2 as unstructured size transition factor.

 
Mesh using 0.9 as unstructured size transition factor.

SURFACE MESHERS

There are three main unstructured surface meshers available in GiD:  ,  and . While MinElem is a special mesher which RFast RSurf MinElem
tries to discretize the geometry using the less number of elements as possible considering a given chordal error criteria, RFast and RSurf try 
to generate the more regular elements as possible based on given mesh sizes.

This is a very simple geometrical model, but user may see the difference between the two main unstructured surface meshers RFast and 
RSurf. RFast mesher generates the mesh of the surface in the 2D iso-parametric space of the surface, and RSurf generates it directly in the 
3D space. This gives that meshers two basic properties:

RFast mesher is faster, but in some cases it may give worse quality elements (more distorted).

RSurf mesher is slower, but in general gives a better quality elements, in special in case of curved surfaces.

In this model the only curved surfaces are the ones of the sphere, and it is hard to see the difference of quality between both meshers. 
However we can see a slight difference between them.

Open the 'Preferences' window (from the 'Utilities' menu) and set the RFast mesher in the Meshing branch. Set the 'Unstructured 
size transitions' factor to 0.6.

Apply changes and generate the mesh.

Repeat this process setting RSurf as surface unstructured mesher.

In the following figure the results meshes of the sphere are shown using RFast an RSurf meshers:
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Mesh of the sphere of the model using RFast mesher. Mesh of the sphere of the model using RSurf mesher.

In complex geometrical models in which the surfaces curvatures are important it is strongly recommended to use RSurf mesher in order to 
get a high-quality final mesh.

If the MinElem mesher is selected, it can be seen that the surfaces meshes of the model are quite different. Specially in planar shapes, 
where few elements are used to generate the mesh, but in some cases they are highly distorted. To appretiate better the difference between 
the meshes generated by MinElem mesher, reset the meshing sizes already assigned (MeshReset mesh data) and generate a mesh with a 
very large mesh size (for instance, 1000).

Mesh of the model using MinElem as surface mesher.

This kind of meshes are mostly used for visualization purposes, or for simulations where the quality of the elements is not crucial, improving 
the performance of the computations due to the reduced number of elements.

It has to be considered that the surface mesher can also be assigned to specific surfaces, so as not all the model is meshed with the same 
one. This can be done in the 'Mesh' menu, by the 'Unstructuredsurface mesher' option.

VOLUME MESHERS

GiD has three unstructured volume meshers (all of them generating tetrahedra): ,  and .Advancing front Tetgen Octree
The main characteristics of them are the following ones:

Advancing front: it is based on advancing front technique. It may be slow, but it typically generates better quality elements.

Tetgen: it is based on Delaunay method, and it is faster than the previous one. In some cases it may lead to poor quality elements 
near the boundaries of the volumes.

Octree: it is an octree-based mesher, which is very fast and robust. This mesher can skip lines which are part of the contours of the 
volume, if they have no specific property assigned.

First of all, reset the meshing data (Mesh->Reset mesh data). 
We will focus on the sphere volume (volume number 3). For this purpose we will not mesh the rest of the entities. So, set 'Mesh->Mesh 
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criteria->No mesh' and select the other volumes of the model, as well as the isolated surface (surface number 18). 
In order to appreciate better the difference between the difference volumes meshers, let's unset the 'Automatic correct sizes' in the Mesh 
branch of the Preferences window (set it to None). Set also as unstructured surface mesher the RSurf one.

Generate the mesh of the model with a size of 0.2 setting the three types of unstructured volume mesher (one mesh for each mesher). The 
results of the mesh are shown in the following figure:

 

Mesh generated with Advancing front and Tetgen mesher

 

Mesh generated with Octree mesher

One can appreciate that the different meshers generate different number of elements, and they are not equally fast. 
The external view of the ones generated by Advancing front and Tetgen is the same, as they are constrained meshers and they use the 
same surface mesh as an input. This is not the case of the Octree mesh, where the regular grid of the octree structure can be appreciated in 
the nodes distribution (specially if we take a look at the mesh in 'render normal' mode, and we rotate it). 
It can also be seen that the lines of the volume surfaces are not represented in the mesh coming from the octree mesher.

Structured mesh

Structured meshes can also be generated in GiD. Structured meshes are the ones got from a predefined pattern, and they are restrictive in 
the topology of the geometrical entities they are applied in.

Structured surfaces must be '4-sided' surfaces; this means that they must have four lines, or four clear angles close to 90 degrees, 
so as the mesher could make a topological correspondence between the contour of the surface and a square.

Structured volumes must have 6 contour surfaces (the mesher will make a topological correspondence between the volume and a 
cube).

Actually, GiD can also generate center-structured surface meshes (which have other topological requirements), but they are not included in 
this chapter.

Let's see an example of how to assign this meshing property, but first of all it is better to unassign the previously assigned meshing 
properties to focus just in this structured part.

In order to unassign the mesh properties assigned to the model click on the 'Reset mesh data' option in the 'Mesh' menu.
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Lets assign structured meshing type to the volume number 5 and surface number 10 (shown in the following figure).

Entities to be set as structured.

In order to set a structured mesh onto a geometrical entity, the number of divisions (or the size) in its contour lines must be set.

Select 'Mesh->Structured->Surfaces->Assign number of cells' and select the surface number 10. Then press ESCAPE to leave the 
selection mode.

Set the number of divisions to 3 and select all its contour lines.

Select 'Mesh->Structured->Volumes->Assign size' and select the volume number 5. Then press ESCAPE to leave the selection 
mode.

Set a size of 0.5 and select the contour lines of the volume.

Now generate the mesh again, and the result mesh should be like the one shown in the following figure:

View of the structured mesh of some entities of the model

The structured pattern of elements is clearly recognized in the entities we have selected. 
Different number of divisions can be set to the different structured directions of the entities. You can try to set different numbers and see how 
the final mesh changes. 
In case of triangles and tetrahedra, the structured mesh comes from an internal splitting of an intermediate mesh made of quadrilateral or 
hexahedra. The way these elements are splitted can be symmetrical or not, depending on the 'Symmetrical structured' variable of the 
'MeshingStructuration type' branch of Preferences window.
Setting the tetrahedra to be symmetric, for example, would give a mesh like the shown in hereafter:
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View of the structured mesh of some entities of the model, setting as 'Symmetric structured' the tetrahedra.

Semi-structured mesh

Semi-structured meshes can be applied to volumes. This kind of meshes follows a prismatic topology, so these volumes must be prismatic: 
two tops can be identified, as well as a number of lateral surfaces (which must be able to be meshed as structured). 
In the model of this course, the volumes number 1, 4 and 5 are prismatic, so they can be meshed with semi-structured volume.

Again, reset the mesh data previously assigned (Mesh->Reset mesh data).

Let's make semi-structured the volumes 1 and 4.

Select Mesh->SemiStructured->Volumes and set as 4 the number of divisions to be assigned.

Then select volumes number 1 and 4 and press ESCAPE to leave the selection mode.

Generate the mesh. The result should be as the one shown in the following figure:

Detail of the semi-structured mesh of the volumes 1 and 4.

CHANGE STRUCTURED DIRECTION

Volume number 1 is topologically prismatic only in one direction, but volume number 4 is prismatic in its 3 directions (as is has 6 boundary 
surfaces). The structured direction of volume 4 has been set automatically by GiD, but user may want to set another one.

Select Mesh->SemiStructured->Set->Structured direction. Then select line 25 (the line labeled in the next figure).
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Line 25, to be set as structured direction.

Generate the mesh again. The resulting mesh should be as this one:

Semi-structured mesh when structured direction of volume 4 is the one defined by line 25.

GiD offers two options to force the structured direction of a semi-structured volume: set the structured direction via a line following that 
direction (the option just done before), or set one of the tops of the prism ('Mesh->SemiStructured->Set->Master surface').

Cartesian mesh

To generate a Cartesian mesh of the model, set this mesh type in the MeshingGeneral branch of the preferences window. Once this option 
is selected, the 'Cartesian' branch appears in the Meshing part of the Preferences window.

We will leave all the default values and generate the mesh with a size of 0.5.

View of the cartesian mesh of the model generated with size 0.5.

It can be seen (in the MeshingCartesian branch of preferences window) that the default Cartesian mesher of GiD (Scan convert) is only 
generating volume elements. To generate line or surface elements, the mesher 'Zmesher' can be used.

Embedded mesh
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For this section, we will work with the model gid_embedded_example.gid e loaded from the folder where the courses material is).  (it can b T
his model have a cubic volume, and the skin surface of a sphere.

As explained before, an embedded model consists in some volumes (the calculation volumes), and embedded regions defined by collection 
of surfaces. In this case, the calculation volume is the cube, and the embedded region is defined with the sphere surfaces.

First of all, select the ' ' mesh type in the Meshinggeneral branch of the preferences window.Embedded

Then, generate the mesh of the model (Meshgenerate), using a general mesh size of 1. The following mesh should be generated:

View of the mesh generated.

As an embedded mesh, it can be seen that the volume mesh is fitted to the calculation volume (cube), and it is not conformal nor body-fitted 
to the embedded region (sphere skin).

A field of signed distances to the embedded contours has been calculated on the nodes of the calculation volume mesh. They are stored 
with the model, and can be appreciated going to the post-processing part of GiD (where they are loaded as a result), and visualizing the 
contour fill of it, or some iso-surface (for instance).
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View of the contourfill of distances on the calculation volume mesh View of the iso-surface of distance equal to 0 of the calculation volume mesh, where the sphere shape can be 

Element types

For this section we need to load the model gid_model_basic_meshing_course.gid

The different element types GiD can generate are the following ones:

Surface: triangle, quadrilateral, circle

Volume: tetrahedra, hexahedra, prism, spheres and points.

There are some limitations in terms of element types permitted depending on the mesh type:

hexahedra and prism elements can only be generated in structured or semi-structured volumes.

Embedded meshes are only implemented for tetrahedra volume elements

Cartesian meshes only generate hexahedra (for volumes), quadrilateral (for surfaces) and line (for lines) elements.

Considering this, selecting an element type is as easy as going to the 'Mesh' menu, setting the 'Element type' and select the desired entities. 
In order to see different types of elements on this model follow this steps:

Reset previous mesh data (Mesh->Reset mesh data).

Set as structured volume number 4, with 5 divisions in its contour lines.

Set as semi-structured volume number 5 with 5 structured divisions.

Set Hexahedra as element type for volume number 4.

Set 'Sphere' as element type of the spherical volume (volume number 3).

Set 'Quadrilateral' as element type of surface number 18.
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To check graphically the element types (or other meshing properties) assigned to the model, the 'Draw' option in the 'Mesh' menu is useful.

Select Draw->Element type->Volumes in order to check the element types assigned. The result should be like the following image:

Different element types assigned to the model volumes shown using the Mesh->Draw option.

Generate the mesh. The resulting mesh should be like the one shown in the following figure:

View of the mesh generated with the different element types assigned.

Note that the element type of volume 5 is prism, but the user has not set it. Just before mesh generation, GiD makes compatible the element 
types of the geometrical entities in order to fit the user requirements.
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Run a CFD simulation

The model to be calculated is the flow of the air around a circle, which could be the section of a cylinder.
Files->Open...
and select the cfd_2d_example.gid model.

Then it is time to load the CFD calculation problem type and assign the material properties and the conditions to the geometry, so as the 
simulation could be run. 
We won't focus this course in the simulation itself or the parameters needed for it, but only in the way of assigning properties and how to run 
a simulation within GiD. 
The boundary conditions and physical properties to use in this simulation are:

Density = 1.225 Kg/m3

Dynamic viscosity = 1.846e-5 Kg/m·s

Fluid velocity = 3 m/s in the X axis direction. There are no flux through lateral walls of the control volume.

Load Kratos problemtype

For loading the problem type you should go to the  menu and select Data->Problem types Kratos
The start data window of the problem type appears. We are going to run a simulation of a  fluid flow, so we must click on the   button. 2D Fluid

Available applications in the Kratos Market.

In the next window, select again  and , Fluid 2D

This will set the kratos tree into a Fluid 2D configuration

Assign fluid material

Materials and properties->Fluid
For applying the fluid material properties double-click on Parts
You can see that a window (like the one shown in the figure) is opened with a data tree containing all the information required for the 
simulation.
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Click in the  button next to the material to set the Air values for density and viscosity. Then, click on the  button and assign the refresh Select
surface. Once selected the surface, click  and End Ok.

Run a CFD simulation > Fluid boundaries

Conditions and initial data->Fluid flow

Unfold the Conditions container of the tree to show the conditions available.

First of all we are going to force the fluid to have null velocity in the 'solid' boundaries of the model, which are the circumference 2D curves 
(that represent the surfaces of a cylinder considering it as a 3D model)

Double-click on  and a window will appear in the lower part.No slip

Click on , and select the circumference lines.Select

Then click  and .End Ok

You'll see that  has been created and binded to the  conditiongroup: No Slip Auto1 No Slip

Now, we are going to set the lateral walls as Slip

Double-click on  and a window will appear in the lower part.Slip

Click on , and select the top and bottom straight lines of the box.Select

Then click  and .End Ok

You'll see that  has been created and binded to the  conditiongroup: Slip Auto1 Slip

Now we are going to set the conditions for the outlet region (the face of the control volume with maximum X coordinate).

Double-click on and a window will appear in the lower part.Outlet pressure 

Ensure the options set are
Not checked  by function

Not checked  Add hydrostatic contribution

Value: 0.0 Pa

Click on , and select the line with maximum X coordinateSelect
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Then click  and .End Ok

You'll see that  has been created and binded to the conditiongroup: Outlet pressure Outlet pressure 

It's time to set the conditions for the inlet region (the face of the control volume with minimum X coordinate).

Double-click on and a window will appear in the lower part.Automatic inlet velocity 

Ensure the options set are
Not checked  by function

Value: 3.0 m/s

Normal direction: Inwards

Time interval: Total

Click on , and select the surface with minimum X coordinateSelect

Then click  and .End Ok

You'll see that has been created and binded to the conditiongroup: Automatic inlet velocity  Automatic inlet velocity 

General data

Now it is time to set the general data for the solver, like solver parameters, etc.

Solution > Parallel configuration

We are going to run this analysis using 8 processors and OpenMP.

Solution > Time parameteres

End time: 20

Delta time: 0.1

Values for the Solution parameters
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Results

Results > General data

Units used for output frequency: Steps

Time steps between outputs: 1

Check properties assigned

Clicking on the tree with the right-mouse button, user can check the information assigned to the model, drawing with colors the different 
conditions, materials, etc... (contextual menu: Draw->Draw groups...) 
Tree items with data applied to groups are highlighted in bold characters 

Meshing

Make sure you are using a Body fitted mesher in Utilities > Preferences > Meshing >General> Mesh type > Body-fitted.

To mesh the model, click on the menu and mesh with Mesh > Generate mesh  mesh size: 0.2

Calculation

You can run the calculation by clicking in the rocket of the left toolbar, or in the menu Calculate > Calculate (F5)

Results

Go to postprocess and check the results.

Extra > CFD 3D

Go back to preprocess and let's create a 3D case.

Go to  The application selector should appear again. This time we are selecting  The Kratos team has Files > New.  Fluid > Fluid > 3D. 
developed an example to show how to run a 3D cylinder in a Air flow.

Click on the book icon in the left toolbar. 

This will generate the geometry and the tree assignations.   can navigate through the tree and see the assigned values. Save the model, You
mesh it and run it. (It may take some minutes).
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Results visualization

Description

The objective of this course is to do a 
postprocess analysis of an already calculated 
fluid simulation around a pyramid building. 

In this course, the project  will be pyramid.gid
used.

Note: the solver used to run this simulations 
was Tdyn, a fluid dynamic (CFD) simulation 
environment based on the stabilized Finite 
Element Method. 

Steps followed in this course:

Loading the model

Changing mesh styles

Visualization of results

Creating images

Loading the model

In this course we will use the pyramid project, so the steps to follow are:

Start GiD

Open the  project with: ,  or clicking on pyramid.gid Files->Open Ctrl-o

Switch to postprocess mode:  or FilesPostprocess

Note: If you are viewing some popups messages and you want to deactivate them you can do it following these steps:

Select UtilitiesPreferences

In  branch choose  in the  optionGeneral Normal Popup messages

Changing mesh styles

Menu
Window->View style...

Description

Select  using the menu bar or clicking on Window->View style...
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Our model is composed by 4 layers. In order to get a better visualization we will disable the volume layer.

Select the  layer and switch it Layer0 off

Select the  layer and switch it Layer8 on

Click on the icon   in the  column or click on the  .Tr

Click on  buttonClose

Play a little with the options of these windows, but to continue the tutorial, let a  style selected for all meshesBody Bound

Viewing the results

Menu
View results
Window->View results...
Utilities->Preferences->Postprocess branch

Description
Several results had been calculated for several time steps. You can check these results through the  menu or opening the View results View 

 window.Results
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The options related with the results visualization can be changed through the  window, in the Postprocess branch. When you Preferences
change an option this one turns to red before apply. To apply the changes click on Apply button.

Iso surfaces and animations

Model used
The model pyramid.gid used in this example can be found at .Material location

Menu
View results->Iso Surfaces

Description
With this result's visualization a surface, or line, is drawn passing through all the points which have the same result's value inside a volume 
mesh, or surface mesh. To create iso-surfaces there are several options.

From preprocess mode open the model

Switch to postprocess mode

Turn off the  and  in order to get a better viewLayer0 Layer8

Set as  the layers styleBody Bound

Select the 12.5 step through  or clicking on  View results->Default analysis/step->RANSOL->12.5

Select  through the menu bar or clicking on View results->Iso surfaces->Automatic width->Pressure(Pa)

After choosing the result, you are asked for a width. This width is used to create as many isosurfaces as are needed between the Minimum 
and Maximum defined values (these are included).

Select the default value 0.182341

Several configuration options can be set via the Preferences window.

Menu
Utilities->Preferences->Postprocess->Iso surfaces
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In order to see the inner zones we will set the transparency on the iso surfaces.

For  option select Transparency Transparent

Move the model to see the inner zones

For  option select again as Transparency Opaque

In order to improve the visualization and to get a more realistic view select View->RenderSmooth

Other interesting options are:

Geometry->Convert->Iso surfaces to sets which consolidates the iso-surface as mesh which can be exported to a file.

Utilities->Preferences->Postprocess->Iso surfaces->Color mode->Contour fill color allows to draw the contour fill of any result 
over the iso-surface. Select this option and then do a contour fill of any result.

Utilities->Preferences->Postprocess->Iso surfaces->Show isolines this options allows the user to switch iso-lines of surfaces 
on or off.

Menu 
Window->Animate

Description
This window allows the user to animate the current visualized results.
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If one result has several steps you can visualize them in an animation. In this case we will use the iso-surfaces result.

Select  or click the icon   to open the animation windowWindow->Animate...

Please notice that we have from step 1 to 9. We will do the animation only of some of these steps.

Check the  option and set 3  9From step to step

Select the  option and set it to 650 ms. The animation should take around 4 secondsDelay between steps

Try it clicking on the  iconplay

We will record a video during the animation.

Once the animation is finished check the  optionSave

You can choose from several video formats.

Select AVI/mjpeg

Please select a folder where the video will be saved clicking on the  icon or writing the pathfolder

Please click on the  button and the recording will begin. This step could take a little bit long. Wait until the red circle turns to play
green

Close the Animate window
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Now we will visualize another result but before we will clear all the results.

Select  through the menu bar or using the icon View results->No results

Result surface

Model used
The model pyramid.gid used in this example can be found at .Material location

Menu 
View results->Result surface

Description
This option uses a result component, or a scalar value, and draws a 3D surface above the mesh following the normals of this mesh.

From preprocess mode open the model

Switch to postprocess mode

In order to get a better view turn off the  and  layersLayer0 Layer8

Select View->Render->Smooth

Select  A surface will be drawn which results from moving the nodes along its View results->Result surface-> Pressure (Pa).
smoothed normal according to the results value for this node

Enter  as factor in the command line20

Due we have positive and negative values please set as  the layers style. Now all the result surface can be seen easilyBoundaries

You can change several options in the Preferences window

Select Utilities->Preferences->Postprocess->Result surface->Show elevations->None

Select  With this last option the surface is colored Utilities->Preferences->Postprocess->Result surface->Draw contour fill.
according to the pressure value

Click on  buttonApply

Play with the other options as you will

Click on  buttonClose

Select  through the menu bar or using the icon View results->No results

Contour fill, cuts and limits

Model used
The model pyramid.gid used in this example can be found at .Material location

Contour fill 
Menu
View results->Contour Fill
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Description
This option allows the visualization of coloured zones, in which a scalar variable or a component of a vector varies between two defined 
values.

From preprocess mode open the model

Switch to postprocess mode

In order to get a better view turn off the  and  layersLayer0 Layer8

Set as  the layers styleBody Bound

Select View->Render->Normal

Please select  through the menu bar, or clicking on  or using the View results->Contour fill->Pressure (Pa) Window->View 
 windowresults...

GiD can use as many colours as permitted by the graphical capabilities of the computer. The number of colours can be set through Utilities-
. A menu of the variables to be represented will be shown, >Preferences->Postprocess->Contour fill and lines->By number of colors

and the one that is chosen will be displayed using the default analysis and step selected.
In the model the pressure has been calculated. We can visualize the result for each step in a contour fill. 

You can choose the step that you want to view through the  window or clicking on View results

Select the step 12.5

Several configuration options can be set via the Preferences window.

 
 Another similar result visualization is  but in this case the iso-lines of a certain nodal variable are drawn. In this case, NOTE: Contour lines

each color ties the points with the same value of the variable chosen.
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Menu
Utilities->Preferences->Postprocess->Contour fill and lines

You can change the color scale in other to get a more comfortable view. You can select several predefined color scales. The default scale is 
 starting from blue (minimum) through green and yellow, to red (maximum).Rainbow,

For  option select Color map Terrain

You can also set your own scale.

For  option select Color map User defined
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Select the button  to open a window.In this window you can change the number of different colors used in the More color options
scale. If you need more accuracy you can increase this number, or decrease it for a higher contrast.

Change the number of colors to 20

Click on  buttonApply

Click on  buttonClose

Click on  button of the preferences windowApply

Cuts 
 Menu

Geometry 
In order to view the inner zone we will do several cuts along the model.



GiD

63Copyright © 2020, GiD, CIMNE 

1.  

2.  

3.  

1.  

2.  

3.  

4.  

5.  

6.  

7.  

8.  

9.  

10.  

1.  

1.  

2.  

3.  

4.  

1.  

2.  

3.  

4.  

We want to cut the inner volume in order to see the pressure in the air. 
First of all we have to make visible the volume.

Select Window->View style...

Select  and make it  clicking on the iconLayer0 visible

Select  through the menu bar or clicking on  and then  Geometry->Cut plane->Succesion

With the  option you specify a line which will be used as axis to create cut planes orthogonal to this axis.succession

NOTE: after clicking the first point, you can press the  key to snap the dynamic line to the screen horizontal, vertical or 45º diagonals. Alt
The number of planes is also asked for.

The axis is defined by two points, please write the first one in the command line 30 200 0

You are asked for the second point, introduce 30 -100 0

Choose  cuts. You should obtain 4 parallel planes to Y axis.4

Select  You can see that several layers had appeared a prefix like . These names can always be Window->View style... CutX
changed through this window

Set off the  again through the  window. You can rotate the model in order to see the contour fill result on the cut Layer0 View style
planes.

In the same window select all the  and click on  button in order to delete all the cuts.CutX Delete

Select Yes

In order to reset the default options for the contour fill, go to Utilities->Preferences->Postprocess->Contour fill and lines

Click on  buttonDefault values

Click on  buttonApply

Define limits
You can set the limit values for the contour fill. In our case we only want to see the positive values. In order to do this we will set the 
minimum value to 0.

. Select  through the menu bar or clicking on Utilities->Set contour limits->Define limits...

Choosing the first option the Contour Limits window appears. With this window you can set the minimum/maximum value that Contour Fill 
should use.

Check the  checkboxMin

Change the value to 0

Click on the  buttonApply

Click on the  buttonClose

Outliers will be drawn in the colour defined in the Out Min Colour option. In order to view it better we will change this color to transparent.

Select Utilities->Preferences->Postprocess->Contour fill and lines->Out minimum color->Transparent

Click on  buttonApply

Select Utilities->Set contour limits->Reset limits 

Select View results->No results
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Combined results

Model used
The model pyramid.gid used in this example can be found at .Material location

Menu
Window->Several results...

Description
Through this window you can select several results in order to visualize them at the same time. From this window you can also delete the 
undesired results visualizations.

From preprocess mode open the model

Switch to postprocess mode

In order to get a better view turn on all the layers except Layer8

Set  transparentLayer0 

Set as  the layers styleBody Bound

In order to see the inner vectors first we will do a cut through the volume. We want a cut parallel to the XY plane and near to the pyramid 
base.

Select  to get a proper view to make de cutView->Rotate->Plane YZ

Select Geometry->Cut plane->2 points

Select 2 points by your own near the pyramid

Press  to leave the cut functionESC

Turn off the Layer0

Change the cut layers style to Boundaries

Select Window->Several results...

In this window select . With this option GiD is told to visualize one result over anotherone over another

Select View results->Default analysis/step->Ransol->12.5

Select View Results->Contour fill->Pressure

Select View results->Display vectors->Velocity (m/s)->|V|
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Select  and select and click on  buttonUtilities->Preferences->Postprocess->Vectors->Color mode By modules  Apply

Select View results->No results

Delete the created cuts

Show min max

Model used
The model pyramid.gid used in this example can be found at .Material location

Menu
View results->Show Min Max

Description
With this option you can see the minimum and maximum value of the chosen result in the chosen analysis step. In our case we will choose 
the Vy component of velocity result for the first analysis step.

From preprocess mode open the model

Switch to postprocess mode

Turn off the  and  in order to get a better viewLayer0 Layer8

Change the style to  for all the layersBoundaries

Select  through the menu bar or clicking on View results->Default analysis/step->RANSOL->15

Select  through the menu bar or clicking on  . The label shows View results->Show min max->Show both->Pressure (Pa)
the node number and the value of the result

Select View results->No results

Display Vectors

Model used
The model pyramid.gid used in this example can be found at .Material location

Menu
View results->Display Vectors
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Description
With this display option the nodal vectors of the chosen result are shown.

We want to display the vectors of velocity in a cut.

From preprocess mode open the model

Switch to postprocess mode

Turn on all the layers except Layer8

Set  transparentLayer0 

Select  throught the menu bar or clicking on View results->Default analysis/step->RANSOL->20

In order to see the inner vectors first we will do a cut through the volume. We want a cut parallel to the YZ plane and near to the pyramid 
center

Select  to get a proper view to make de cutView->Rotate->Plane XY (Original)

Select Geometry->Cut plane->2 points

Select 2 points by your own or enter the following coordinates in the command line. 30 200 and 30 -100

Press  to leave the cut functionESC

Turn off all the layers except the ones with name  in order to only see the cutCutX

For all the cut layers change the style to Boundaries

Select View results->Display vectors->Velocity (m/s)->|V|

Menu
Utilities->Preferences->PostprocessVectors
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For  option select  in order to see the vectors by colors depending on their valueColor Mode By modules

The option  turns on. Enter 50 and click on   to get more accuracyNumber of colors Apply

For  option, enter 5 and click . This option changes the number of displayed vectorsFilter factor Apply

Click on  buttonClose

Delete the layers with name CutX

Select View results->No results

Stream lines

Model used
The model pyramid.gid used in this example can be found at .Material location

Menu
View results->Stream Lines

Description
With this option you can display a stream line, or in fluid dynamics, a particle tracing, in a vector field.

From preprocess mode open the model

Switch to postprocess mode

Turn on all the layers except Layer8

Set  transparentLayer0 
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Set as  the layers styleBody Bound

We want to create some stream lines near the pyramid center in order to plot the velocity result near it. So we will make a cut near the 
center and we will select there the points where we want to plot the stream lines. We want a cut parallel to the XZ plane and near to the 
pyramid center.

Select  to get a proper view to make de cutView->Rotate->Plane XY (Original)

Select Geometry->Cut plane->2 points

Select 2 points by your own or enter the following coordinates in the command line. -70 78 and 130 78

Press  to leave the cut functionESC

For each cut created change the style to Body Lines

To get a better view set off all the layers except the ones with name CutX

Select View->Rotate->Plane XZ

Select  through the menu bar View results->Stream lines->In a quad->Velocity (m/s)

With this option you can define a quadrilateral area which will be used to create a N x M matrix of points. These points will be the start for the 
stream lines. 
We want to create several stream lines around the pyramid.

Note: This action could also be done clicking on   in the icon bar. In this case we have to select the way to define the start point 
through the mouse menu. In this case select Contextual->In A Quad.

From the mouse menu (right button click) select Contextual->Join Ctrl-a

Define a quadrilateral area near the pyramid shape clicking on 4 mesh points

You are asked for the  in the quad. Enter 5,5 and click number of points Ok

The stream lines are created.

Click the middle mouse button or press the  key in order to finish the operationESC

Turn off the cuts layers and set on the layers  and Layer4 Layer9

Menu
Utilities->Preferences->Postprocess->Stream lines
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Select Utilities->Preferences->Postprocess->Stream lines

In color mode section, select  option. The stream lines will be drawn with the colors used in the velocity Stream contour filled
contour fill

In render options section,change the  toLine size  2

And select  option in order to draw the stream lines with trianglesQuality->Nice

And . With this option the streams show the swirl of the velocity field Detail->Ribbons

Click on Apply

Change the to  againDetail 4 sided prism

Check the Show optionarrows 

Set  for the  option20 Size

Set  for the  option20 Spacing

Clilck Apply

Click on  buttonClose

Select View results->Delete->Stream lines->All

Delete the created cuts

It's also possible to save the stream lines for next sessions.

Select Files->Export->Post information->Stream lines...

Choose the location where you want to save them and click on Save
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Then you can import them with Files->Import->Stream lines...

Graphs

Model used
The model pyramid.gid used in this example can be found at .Material location

Menu
View results->Graphs

Description
From this menu several graphs types can be created, we will try some of them. Graphs are supported for results defined over nodes.
Graphs are organized into  in order to ease the management. Each set shares the same units for each axis. graph sets
When a graph is created is placed in the current graphset if the units are the same, otherwise a new graphset is created. 
In order to work with graphs we will use the 'graphs window'.

From preprocess mode open the model

Switch to postprocess mode

Turn on  the layers except the  through the  windowall Layer8 View style

Change the mesh style to  for all the layersboundaries

The  graph displays a graph of the evolution of the selected result along all the steps, of the default analysis, for the selected Point evolution
nodes.

Select View results->Graphs->Point evolution->Pressure (Pa)

Write 30 65 15 in the command line in order to specify the point

Affter pressing the  key, or the middle mouse button, the graph will be shown in a separate window:Escape

The graph is created in the graphset-1. We will create another graph in the same graph set.

The  displays a graph defined by the line connecting two selected nodes of surfaces or volumes, or any arbitrary points on any Line graph
projectable surface and in any position.

Select View results->Default analysis/step->RANSOL->0

Select View results->Graphs->Line graph->Pressure(Pa)

Write 30 -100 0 in the command line in order to specify the initial point

Write 30 200 0 in the command line in order to specify the final point

Now both graphs are shown in the same graph set:
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Note: probably it is a bad idea to represent both kind of graphs in the same graphset x-y space, because the x axis for the 'Point evolution' 
represents the time step (e.g. seconds) and for the 'Line graphs' represent a spatial distance (e.g. meters).

We will rename the graph set.

In the top part of the window click the  icon

A window will appear asking for a new name. Enter 'Pressure', for example

We will create a new graph set.

In the top part of the window click the  icon

A new graph set is created with default name 'graphset-1'. When a new graph set is created becomes the current one. We can see that 
there are no graphs on this new graph set.
It's also possible to create graphs from the graph window.

Go to  tab and select  int  optionCreate Point Evolution View

In  list double click Y Axis Velocity (m/s)->|V|

Write 30 65 15 in the command line in order to specify the point

Press  to finish the graph.Escape

We can manage graphs and graphs sets in the Options panel. Depending if we are selecting a graph set or a graph in the tree we will see 
different options in the tab.

Go to the  panel, select the 'Pressure (Pa) evolution at (30, 65, 15)' graph and delete it pressing the button with the red Options
cross.

A confirmation window appears. Click .Yes

Please notice that the current graph set have been changed to 'Pressure'. Now the Plot graph panel will show only three graphs:
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The graph size is re-adapted. We will change several style options of a graph.

Double click in any point of one graph and we will access to the  tabOptions

Choose  in the  optionLine Style

Set to red the  option. You can do it writing #ff0000 (hexadecimal values of red, green and blue color components) or selecting Color
the white color clicking on the right color window

Set to 4.0 the Line width

Click on  buttonApply

Graph sets options can be managed selecting the set in the tree.

Select 'Pressure' branch. The options will change.

For instance mark 'Logarithmic scale' option in Y axis.

Click on  buttonApply
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We can export the graph information in order to open it later with GiD.

Select . You are asked for the location where to save the .grf fileFiles->Export->Graph->All graphsets

Choose the location

Now you can import the graphs selecting Files->Import->Graph...



GiD

74Copyright © 2020, GiD, CIMNE 

Animations

This tutorial explains several details which should be taken into account when an animation is created for a later presentation. 
Then an example is used showing tips regarding the creation of presentation videos.

Basic rules

The two most important rules when creating an animation are:

which is the , i.e. where should your video be reproduced, andtarget of your animation

save the data used to create the video, including , because surely the video should be recreated with small view, size and results
modifications.

The basic rules that should be followed when creating an animation are:

Target of the animation: if the animation is to be included in a presentation to be projected, usually projectors have a resolution of 
1024x768 or 1280x720, and your desktop monitor is 1680x1050 or 1920x1080.

Size of the window: avoid creating videos in full-screen mode. In full-screen mode, the videos will be very big and, when the 
presentation reduces the resolution to fit the projector, details will be lost and text will become unreadable. Use the Resize graphical 

 macro (  ) or the Resize option in the Window --> Animate window or the render size control macros, which define the window
size of the graphical view of the model. These options are also useful to resize the graphical window between sessions. You can 
use this macro to guarantee the size of the graphical window when changing from pre to post or between gid sessions.

Resize button in the animation control window
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Macros to control the rendering window size

Views: centre your region of interest and save the view using . This way the view can be used to do different View --> Save
animations, or glue together different animation chunks.

Format: there are several compression formats, but the recommended ones are:
AVI/MS Video 1 : , although is very old, it's the most compatible and videos created with Recommended for presentations
this compression can be embedded in presentations without problems and all video players can reproduce them.

MPEG : uses the MPEG2 codec, it's also supported every where, although in MS Windows some problems can appear if 
the resolution used is bigger than 720x576.

Macromedia Flash Video ( flv) : , uses the "screenvideo" compression, but needs a player ( like any Recommended for webs
other video) if the animation is included in a web page.

GIF : to include the video as picture in a web page. Bear in mind that the colour quality may be adversely affected by the 
drastically reduced palette, only 256 colours can be used. Try the different gif options to select the best for your animation.

Graphical objects: graphical objects, like legends, comments or axes can be placed anywhere in the screen using the Utilities --> 
Tools --> Move screen objects .

Background: despite the configuration of the viewed background, when creating a video the background settings are controlled 
through the :File --> Page and capture settings

 

Background options used to create videos

 
Resolution and background options used to capture images

Note: the  options in the above window is very useful to create images of increased size needed for publications like posters, Resolution
articles or books. This options is not used to create high-resolution videos.

Perspective: use perspective for a better perception, can be enabled through View --> Perspective...

Stereoscopy (3D)

Stereoscopy can be enable through the window View --> Advanced view settings

Perspective: use perspective for a better perception, can be enabled from the same window or through View --> Perspective...

Full-screen: a better 3d experience can be achieved in full-screen mode, by pressing  or .F11 View --> Full screen
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Colours: if the stereo mode used is the Anaglyph colours, the colour palette is drastically reduced, because some colours are only 
viewed by one eye and not by the other producing discomfort. The appropriated colours depends on the colour filters used. If 3d 
colour filters used are red and cyan, most of the cases, then there is a special contour fill colour map for this mode, under Option --> 

, if the 3d colour filters used are red and cyan.Contour --> Colour scale --> 3D anaglyphs

Useful colours for red & cyan stereoscopy are greys, white, magenta and yellow.

Saving videos: at the bottom of the  there is an option called  which can be used Animate window Create a stereoscopic animation
to save stereoscopic animations, which can be reproduced with the proper player. In these videos, the image for the left eye and the 
one for the right eye are saved in the same frame, i.e. doubling the horizontal resolution of the frame, and the player splits these left 
and right images and alternates them in the output. Stereoscopic animations can also be created in non-stereo computers.

Example

Model used in this example:

This example is a simulation of a very simple wave generator, which has different meshes at different time-steps. The file wave_generator.
post.bin can be found at .Material location

First observation: resolution

Load the , file which can be found at ;wave_generator.post.bin Material location

do a contour fill of  and maximize the window;Pressure

with  move the legend to the upper left corner;Utilities --> Tools --> Move screen objects

now create an animation:
with a  of ,Delay between steps 1000 ms

with  enabled,Automatic limits

using the  compression codec,AVI/MS Video 1

and save the animation;

now reduce the size of the graphical window to 640x480 and save the animation with another name;

reproduce both animations reducing the player window to half of the screen;

it can be observed that the legend information can not be read in the first animation, but in the second;
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1.  

2.  

3.  

4.  

5.  

6.  

7.  

Single frame from a full screen video, in which the legend text can not be read. Single frame from a video with a resolution of 640x480, now the 
legend text can be read.

Second observation: perspective

With the same example, just select Results --> No results

rotate the model so that the wave comes to you;

play the animation;

enable perspective ( );View --> Perspective

Set log10 distance: -0.4; Apply changes;

play the animation again;

is there a difference?

Wave going away from the user with no perspective Wave going away from the user with perspective

Perspective option enabled

Third observation: 3D
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1.  

2.  

3.  

1.  

With the same model, open the  window;View --> Advanced vieweing settings ...

now enable the stereoscopic view:
some settings may need an adjustment, like the , which depends on each viewer;eye distance

there is a bad  due to the bad colours:3D perception
the  mesh is sky blue, and therefore only the right eye sees it and the left eye only sees a black region ( try closing liquid
one eye and then the other onr);

try doing a contour fill, for instance of the |Velocity| result, some coloured regions are better perceived than other ( try again 
closing one eye and then the other);

play with the animate window

Only the right eye can see the model The right eye only sees a black spot, producing some discomfort

correct the colours:
try choosing different colour for the meshes, like grey, yellow, or magenta;

in the contour fill just select Utilities --> Preferences --> Postprocess >Contour fill and lines --> Color map --> 3D anaglyphs  
or , this is a special colour map which uses colours visible by both eyes at the same time when the user is 3D anaglyphs 2
using the red-cyan glasses;
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1.  

2.  

Meshes drawn using grey and gold like colours which can be seen from both eyes

Contour fill of |Velocity| using the 3D anaglyphs colour scale

play the animation again;

press  to enter Fullscreen modeF11


	Introduction
	GiD basic courses
	Basic GiD management
	Geometry creation and edition
	Meshing basic features
	Run a CFD simulation
	Results visualization
	Animations


