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Static Analysis of a Beam

This example describes a static linear elastic analysis of a beam with double T section under several static loads.

The following list is a summary of all steps of tutorial:

Create geometry of a beam with double T section.
Create a finite element model of this beam.
Run static analysis of the model.

Description of Model:

Determine displacements and reactions in pinned points of a beam with double T section under several static loads.

Properties:

Length 100 inch

Height (Section) 2 inch

Width (Section) 1 inch

Thickness (Section) 0.1 inch

I1 0.229 inch4

I2 0.017 inch4
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1.  

1.  
2.  
3.  

For basic reference, this example can be found in the distribution, directory Examples/Nastran and with the name staticbeam.gid

Procedure:

Start:

1- Open a new project, right click on this icon in taskbar  
2- Load problem type Nastran. Follow the menu sequence below: 
Data -> Problem type  nastran 
Appears a splash image and the name of the master window changes to NASTRAN Interface. 
3- Change the view plane to XY: 
View -> Rotate -> Plane XY (original)

Create geometry:

Create line.

Geometry  Create  Straight line

Insert coordinates of points to the command line to define the beam (line). Command line is in the bottom of GiD master window.

     1  point         -> 0,0st

     2  point        -> 30,0nd

     3  point        -> 60,0rd

     4  point        -> 120,0th

  (It is only necessary to introduce points using two coordinates, the third coordinate Z is assumed to be 0).

Press escape or middle button of mouse.

Define Local Axes

The model has been created related to a global axes system XYZ that is unique for the entire problem. But every beam must have its own 
local axes system X’Y’Z’ in order to:

Refer section properties like  or  and  to this system.Inertia modulus thickness height
Some of the loads (that have the prefix ) are related also to this system.Local
Strength results over the beam are referred to this local axes system.

The main property of this system is that the local X’ axe must have the same direction than the beam.
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1.  

1.  

2.  

3.  

1.  

The ways for defining local axes systems are:

Default. The program assigns a different local axes system to every beam with the following criteria:

X’ axe has the direction of the beam.
If X’ axe has the same direction than global Z axe, Y’ axe has the same direction than global X. If not, Y’ axe is calculated so as to 
be horizontal (orthogonal to X’ and Z).
Z’ axe is the cross product of X’ axe and Y’ axe. It will try to point to the same sense than global Z (dot product of Z and Z’ axes will 
be positive or zero).

Note: The intuitive idea is that vertical beams have the Y’ axe in the direction of global X. All the other beams have the Y’ axe horizontal and 
with the Z’ axe pointing up.

Automatic. Similar to the previous one but the local axes system is assigned automatically to the beam by GiD. The final orientation 
can be checked with the  option in the GiD Conditions window.Draw Local Axes
Automatic alt. Similar to the previous one but an alternative proposal of local axes is given. Typically, User should assign 
Automatic local axes and check them, after assigning, with the  option. If a different local axes system is desired, Draw local axes
normally rotated 90 degrees from the first one, then it is only necessary to assign again the same condition to the entities with the Au

 option selected.tomatic alt
User defined. User can create different named local axes systems with the GiD command: Data->Local axes->Define

and with the different methods that can be chosen there. The names of the defined local axes will be added to the menu where Local axes 
are chosen.

In this example we will assign automatic local axes:

Data -> Properties -> Local Axes

Set statement Local Axes to Automatic (An automatic local will defined for all lines selected).

Select all lines of the geometry.

Assign property and material:

Define a new material.

Data  Materials 

Click on the following icon to create a new material:  
Enter name for the new material  alum.
Fill all statements like in the picture:
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And set density, in Others page, to 0.101

Click on the following icon to save the new material: 

2- Define and assign properties for the beam.

Data  Properties  Property

You can go directly to the property window by clicking on this icon:  without closing the material window and going back to the menu.

Select option  in the menu.property

Select property  from the top combo box.beam

Click on the following icon to create the new property:

Enter a name for the new property .’cantilever’

Fill all statements as in the following picture:
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You have to select the previously created material in Composition Material.

Click on the following icon to save the new property:

Now click the  button, and select all lines of the geometry.Assign

To see if the property is well assigned click on  button, select option.Draw This property 

The NASTRAN Interface program window should look like this:

Assign Constraints:

1- Assign prescribed displacements and rotation. 
Data-> Boundary Conditions -> Constraints 

Click on the following icon to set the condition over points: 



Nastran-GiD interface

9Copyright © 2021, GiD, CIMNE 

1.  

1.  

Assign the following prescribed movements:

X-Displ Y-Displ Z-Displ X-Rot Y-Rot Z-Rot

Point A 1 1 1 1 1 0

Point C 0 1 1 1 1 0

Point D 0 1 1 1 1 0

Connections

Disconnect degree of freedom from point B.

Data  Boundary Conditions  Connections 
Checks disconnect Z-Rotation statement. 

Click on  button and select point B.Assign

With this condition it is possible to disconnect some degrees of freedom of the union points of some beams. In this example this condition 
creates a 2-D ball-joint in XY-plane.

Assign Static Loads

Assign static punctual loads.

Data  Loads  Static Loads 

Click on the following icon to set the condition over points: 

Point A
Select from the top combo box static load Moment.

(Mx-Force, My-Force, Mz-Force) = (0,0, -60)

Click on  button and select point A.Assign

Point B

Select the static load  from the top combo boxPoint-Force-Load .

(X-Force, Y-Force, Z-Force) = (0, -20, 0)

Click on  button and select point B.Assign

2- Assign static distributed loads. 
Data  Loads  Static Loads 

Click on the following icon to set the condition over lines: 
Line from C to D
Select from the top combo box static load Line-Pressure-Load.
Coord. System = BASIC
(X-Pressure, Y-Pressure, Z-Pressure)= (0, -40, 0)

Click on  button and select the line C to D.Assign

Mesh the Geometry:
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1.  

1-Create a mesh. 
Meshing  Generate 
Now you are asked about the size of elements to be generated, change to value 6. 

Click on  button OK
Appears a window with information about the mesh:

Num. of linear elements = 20
Num. of nodes = 21

Perform the Analysis:

Design Executive Control Section.

Data  Problem Data  Executive Control

Select type of NASTRAN will be use in the analysis. 
Check STATICS and leave all the other statements uncheck. 
Leave the rest of statements with the default values. 
Click on  button.Accept Data

2 - Design Case Control Section. 
Data  Problem Data  Case Control

2.1. - Input data 
Leave all statements with default values. 
2.2. - Output data

Set Title to “Beam_example”

Select which format file you want to use:

-Small: Every file of a Bulk Data statement will use the 8-characters definition.

- Large: Every file of a Bulk Data statement will use the 16-characters definition.

Leave Subtitle, Label … and Post process with default values.

Check Displacements and constraint forces and uncheck the rest of output requests.

In the Output Design section leave the default values.

Note: If you want to post process the results of MI/NASTRAN analysis with NASTRAN Interface, you have to set the output device to 
PUNCH.

Click on  button.Accept Data

Obtain Input File for NASTRAN Code:
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1.  

1.  

1.  

Option 1:

Calculate  Calculate

Option 2:

Files  Export  Calculation File

Select a folder and a file name to write the file. It is very important to write the correct extension of the NASTRAN input file (i.e. *.nas, *.dat, *.
nid …).

Post process:

Click on the following icon to enter in the post process: 

Import punch file:

Import the punch file (***.pch) obtained from NASTRAN.

Files  Import  Import PUNCH

When the file import process is finished, close the file-find window.

Import FEMAP ASCII neutral file:

Import the FEMAP ASCII file (***.neu) obtained from NE/NASTRAN.

Files  Import  FEMAP file

When the file import process is finished, close the file-find window.

Note: To obtain a FEMAP ASCII file in NE/NASTRAN go to NASTRAN editor:

Setup  Default Analysis Options 
Selects RSLTFILETYPE and set to FEMAP ASCII in Output Control Directives 

Visualization of results:

Contour Fill.

View results  Contour Fill 
Select "Displacements".
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1.  

1.  

Contour Fill Displacements

Deformation

View results  Deformation 
Select "Displacements".

Deformation Displacements

Line Diagram

View results  Line Diagram 
Select  and option Y-DisplacementsScalar

. 
Now change the setting for line diagram. 
Options  Line Diagrams  Show elevations 
Select option Filled line.

Scalar Line Diagram of Y-Displacements
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1.  

Static Analysis of a Gear

Create geometry to represent a gear with octagonal axis. Create a finite elements model of gear. Run static analysis of the gear.

Purpose:

Create geometry to represent a gear with octagonal axis. Create a finite elements model of gear. Run static analysis of the gear.

Description of the Model:

Determine different results of linear static analysis of a gear pinned at the ends of axis with a normal pressure on one tooth.

Procedure:

Start:

Open GiD file called pieza.gid. This file is localized in the Examples folder in the GiD installation directory.
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1.  

1.  

To get this file, use the Internet Retrieve option of GiD and download Nastran Examples.
Internet Retrieve option is available under: 
Data ->Problem Type -> Internet Retrieve
For more information see GiD manuals.

Comment:

If you want to create the gear's CAD model manually without downloading it, see the Post-process Tutorial of GiD, which can be obtained 
from the GiD web page in Support section.

Preferences:

With the target to obtain a good mesh some changes in meshing preferences of GiD have to be made.

Open Preferences window:

Utilities -> Preferences

Select meshing tab and set window entries to the following values:

Surface mesher: Rsurf
Mesh until end
Automatic correct sizes
Unstructured size transition: 0.6
Smoothing: High Angle
No mesh frozen layers
Allow automatic structured 
These settings will prevent the creation of tetrahedron elements with seek angle bigger than 80 degrees. Please note, that gear's CAD 
model is designed like unique volume to allow the creation of a correct finite elements model.

Assign Property:

1- Define and assign the property for the surface. 
Data -> Properties -> Property 
Select from the top combo boxes the property . Tetrahedron

Click on the following icon to create a new property: 
Enter name for the new property . gear
Fill all statements like in the picture:

Make sure, that a one of the default materials is defined in Composition Material. 

Click on the following icon to save the new property: 
Now click on  button, and select the unique volume of the geometry. Assign
To make a proof if the property is well assigned click on  button, select  option. Draw This property
The following image should display the chosen property. :
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Assign Constraints:

1- Assign prescribed displacements and rotation. 
Data-> Boundary Conditions -> Constraints 
Click on the following icon to set the condition over surfaces:

 
The model has the two lids of octagonal axis pinned, which means that all degrees of freedom have to be prescribed.
To do this it is necessary to check all statements. 
2- Select the two lids of octagonal cylinder (axis of the gear).

Assign Static Loads

Assign Normal distributed pressure over one tooth of the gear. 
Data -> Loads -> Static Loads 
Click on the following icon to set the condition over surfaces:

From the top combo box static load select N  ormal-Surface-Load.
Set the value of the load to  (positive sign means that2e4
load is oriented inward to the surface) and select the three interior surfaces of one tooth of the gear, as stated in the following image:
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Perform the Analysis:

Design Executive Control Section. 
Data -> Problem Data -> Executive Control 

 .Select the NASTRAN Type that will be used for the analysis
Check STATICS and leave all the other statements uncheck or with default values. 
Click on  button. Accept Data
2 - Design Case Control Section. 
Data -> Problem Data -> Case Control 
2.1. - Input data
In this example we don't consider the acceleration due to the gravity. Leave all statements with default values. 
2.2. - Output data
Set Title to "Gear_example" 
Select which format file you want to use:
-Small: Every file of a Bulk Data statement will use the 8-characters definition.

Large: Every file of a Bulk Data statement will use the 16-characters definition. 
Check Displacements, constraints forces, elements forces and elements stresses, uncheck the rest of output requests. 
In Output Design section leave the default values. 
Note: The output device has to set to PUNCH for post-processing with MI/NASTRAN Interface. 
Click on  button. Accept Data

Obtain Input File for NASTRAN Code:

Option 1:

Calculate -> Calculate 

Option 2:

File -> Import/Export -> Write Calculation File 
In the Save File window, select the filename and location. Please note, it is very important to use the appropriate NASTRAN file 
extension. 

Post process:

Click on the following icon to enter in the post process: 

Import punch file:

Import the punch file (*.pch) obtained from NASTRAN.
File -> Import -> Import PUNCH 
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Select the *. pch file located in NASTRAN results folder.
After the importing process is finished, close the window. 

Import FEMAP ASCII neutral file:

Import the FEMAP ASCII file (*.neu) obtained from NE/NASTRAN.
File -> Import -> FEMAP file 
Select the *.neu file located in NASTRAN results folder.
After the importing process is finished close the window. 
Note: To obtain a FEMAP ASCII file in NE/NASTRAN go to NASTRAN editor: 
Setup -> Default Analysis Options 
Selects RSLTFILETYPE and set to FEMAP ASCII in Output Control Directives. 

Results visualization:

Open View results window. 
Windows -> View Results 

Contour Fill

In View results window:
Set View to .Contour Fill
Set Results to  total translation
Set Component to total translation modulus.
Click on  button.Apply

Contour Fill Total Translation

Display Vectors

In View results window: 
Set View to .Display Vectors
Set Results to  total spc forces
Set Component to total spc forces modulus.
Click on  button.Apply
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Display Vectors total spc forces

Of course there are more results and more possible visualizations, user is invited to explore all possibilities of GiD. 
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Direct Frequency Response Analysis

Create geometry to represent a flat rectangular plate. Create a finite elements model of plate. Use a dynamic frequency dependent load 
Write an input file for MI/NASTRAN to run dynamic analysis in direct formulation. Use post-processing tools to analysis results.

Purpose:

Create geometry to represent a flat rectangular plate.
Create a finite elements model of plate.
Use a dynamic frequency dependent load
Write an input file for MI/NASTRAN to run dynamic analysis in direct formulation.
Use post-processing tools to analysis results.

Description of Model:

Determine the frequency response of a 5x2 inch flat plate under frequency-varying excitation by using the direct formulation.
A unit load at a corner of the tip will excite the plate model.
A frequency step of 20Hz will be used for this analysis within the range of 20 and 100Hz.
Structural dumping will be set to 0,06.

Properties:

Length 5 inch

Weight 2 inch

Thickness 0.1 inch

Mass Density 0.282 lbs/inch3

Young's Modulus 30.0e+6 lbs/inch2

Poisson's Ratio 0.3

Procedure:

Start:
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1.  

1.  

1.  

1- Open a new project, right click on this icon in taskbar 
2- Load problem type Nastran. Follow the menu sequence below: 
Data -> Problem type -> nastran 
Appears a splash image and the name of the master window changes to NASTRAN Interface. 
3- Change the view plane to XY: 
View -> Rotate -> Plane XY (original)

Create geometry:

Create contour lines of the plate.

Geometry -> Create -> Line 
Now insert in command line the coordinates of points to define the plate. Follow the order is very important. 
First point -> 0,0
Second point -> 5,0
Third point -> 5,2
Fourth point -> 0,2
Fifth point -> 0,0 
(Only it is necessary introduce points using two coordinates, the third coordinate Z is assume to 0 ). 
Now you are asked if you want to join the first point and 
the fifth point , select  Join
Press escape or middle button of mouse.

Create surface.

Geometry -> Create -> NURBS Surface -> By contour 

Or a more quick option is click on the following icon: 
Situated in right vertical tool bar. 

Now the pointer of mouse change to this form  
It means that now is possible select the four lines created before to create the surface. 
Select the four lines in the screen. 
Press escape or middle button of mouse. 
Now in the NASTRAN Interface program window has to be geometry like this:

Assign property and material:

Define a new material.

Data -> Materials 
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Click on the following icon to create a new material: 
Enter name for the new material  mat_1
Fill all statements like in the picture:

Click on the following icon to save the new material: 
2-Define and assign the property for the surface. 
Data -> Properties -> Property 

If you don't close material window is possible get the property window clicking on the following icon 
and select option "property" in the menu. 
Select from the top combo box the property . membrane

Click on the following icon to create a new property: 
Enter name for the new property . property_1
Fill all statements like in the picture:

Look that in Composition Material there is selected the material created before.

Click on the following icon to save the new property: 

Now click on  button, choose Surfaces and Assign
select the surface of the geometry. 
To make a proof if the property is well assigned click on  button, select  option. Draw This property
Now in the NASTRAN Interface program window has to be an image like this:
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1.  

1.  

1.  

Assign Constraints:

Assign prescribed displacements and rotation.

Data-> Boundary Conditions -> Constraints 

Click on the following icon to set the condition over lines: 
Uncheck Z-Rotation and leave all other statements check. 
Now click on  button and select the vertical line on the left side (line number 4). Assign
Note: It is possible label geometry entities using this option:
-Press right button mouse to get the contextual menu.
-Select option Label and choose All.

Assign Dynamic Load

Define the table of interpolation values associate to dynamic load.

Data -> Loads -> Tables 

Click on the following icon to create a new table: 
Enter name for the new table . freq_var
Data Entry

Check Single Value

X= 0.0 and Y= 1.0

Click on  buttonAdd

X=1000 and Y= 1.0

Click on  buttonAdd

Click on the following icon to save the new table: 

Click on  button.Close
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1.  

1.  

Assign dynamic load.

Data -> Loads -> Dynamics Loads 

Click on the following icon to set the condition over points: 
Select from the top combo box dynamic load . Freq Dynamic Type1
Fill all statements like in the picture:

Look that for Table Interpolation Values D[f] has value  is the default value for this statement an is equal to a blank table, it Table. Table
means that D[f] is equal to zero function. 
Now click on Assign button and select the right bottom point (point number 2). 
Click  button. Close

Mesh the Geometry:

1-Create a structured mesh. 
Meshing -> Structured -> Surfaces 
Select the surface of the geometry. 
Press escape or middle button mouse. 
Now you are asked for number of cells to assign to lines, set to 10. 
Click  button. OK
Select lines 1 and 3, the large ones. 
Press escape or middle button mouse. 
Now you are asked again for number of cells to assign to lines, set to 4. 

Click  button. OK
Select lines 2 and 4, the short ones. 
Press escape or middle button mouse. 
Click  button.Cancel

Generate the structured mesh.

Meshing -> Generate 

Now you are asked about the size of elements to be generate, leave default value (0.54) 
Click  button OK
Appears a window with information about the mesh:
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1.  

Num. of Quadrilateral elements = 40
Num. of nodes = 55 
Click  button. OK
Note: It is possible label mesh elements and nodes using this option:
-Press right button mouse to get the contextual menu.

 -Select option Label and choose All.
Now in the NASTRAN Interface program window has to be an image like this:

Perform the Analysis:

Design Executive Control Section.

Data -> Problem Data -> Executive Control 
Select type of NASTRAN will be use in the analysis. 
Check STATICS and DIRECT FREQUENCY RESPONSE and leave all the other statements uncheck. 
Leave the rest of statements with the default values. 
Click  button. Accept data
2 - Design Case Control Section. 
Data -> Problem Data -> Case Control 
2.1.- Input data 
Leave all statements with default values. 
2.2.- Output data 
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1.  

1.  

1.  

1.  

1.  

Set Title to  "Direct_frequency _Response"
Leave Subtitle, Label … and Post process with default values. 
Check Displacements and Velocity, and uncheck the rest of output requests. 
In Output Design section leave the default values. 
Note: If the user wants to post processing the results of the analysis with MI/NASTRAN Interface is mandatory that the output device has to 

 set to PUNCH.
Click  buttonAccept data

Design Dynamic Analysis.

Data -> Problem Data -> Dynamics 
Set these values to the different statements: 
Solution Method = Direct
Domain of Solution = Frequency 
Overall Structural Damping Coeff. = 0.06 
Frequency Step
Initial step = 20
Frequency Increment = 20
Number of frequency increments = 49 
Mass formulation = Coupled 
Click  buttonAccept data

Set PARAM values.

Data -> Problem Data -> PARAM 
In MI/NASTRAN tab set WTMASS to 0.00259
Leave the rest of statements with default values. 
Click  button.Accept data

Obtain Input File for NASTRAN Code:

File -> Import/Export -> Write Calculation File 
Appears a window to select in which folder and the name for save the file. It is very important write extension of the file in the name.

Post process:

Click on the following icon to enter in the post process: 

Import punch file:

Import the punch file (***.pch) obtained from NASTRAN.

File -> Import -> Import PUNCH 
Appears a window to select the punch file located in NASTRAN results folder. 
After importing process is finished close the window.

Import FEMAP ASCII neutral file:

Import the FEMAP ASCII file (***.neu) obtained from NE/NASTRAN.

File -> Import -> FEMAP file 
Appears a window to select the *.neu file located in NASTRAN results folder. 
After importing process is finished close the window. 
Note: To obtain a FEMAP ASCII file in NE/NASTRAN go to NASTRAN editor: 
Setup -> Default Analysis Options 
Selects RSLTFILETYPE and set to FEMAP ASCII in Output Control Directives 

Visualization of results:

Contour Fill.

View results -> Contour Fill 
Select one of the results displacements or velocity.
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1.  

1.  
2.  

1.  

Contour Fill Z-Displacement Step 20Hz

To change step of analysis use this menu sequence: 
View results -> Default Analysis/Step -> 1 
Select that step you want to see.

Deformation.

View results -> Deformation 
Select one of the results displacements or velocity. 

Use trackball rotation to rotate the plate and see better the deformation. 

Numerical results:

To see numerical results in nodes, click on this icon  
and select in which nodes you want to see the current numerical results display in the screen. 
For example: 
Node 51 step 200Hz 
Displacements

X= 1.28075e-19 Y= -4.89892e-20 Z= -0.00547175 Dis. =0.0547175

Velocity

X= -1.23013e-19 Y= -5.22769e-19 Z= 0.467011 Vel. = 0.467011

Create an Animation:

Select which kind of results will be displayed
Open Animation Window.

Windows -> Animate

Click  button.Play
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Modal Analysis of a Beam

Create geometry to represent a beam with double T section. Create a finite elements model of beam. Run modal analysis of the beam.

Purpose:

Create geometry to represent a beam with double T section.
Create a finite elements model of beam.
Run modal analysis of the beam.

Description of Model:

Determine the first three modes of a beam whit double T section, using Givens method for eigenvalues extraction.

Properties:

Length 100 inch

Weight (Section) 2 inch

Width (Section) 1 inch

Thickness (Section) 0.1 inch

I1 0.229 inch4

I2 0.017 inch4

Procedure:

Start:
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1.  a.  

1.  a.  

1- Open a new project, right click on this icon in taskbar 
2- Load problem type Nastran. Follow the menu sequence below: 
Data -> Problem type -> nastran 
Appears a splash image and the name of the master window changes to NASTRAN Interface. 
3- Change the view plane to XY: 
View -> Rotate -> Plane XY (original)

Create geometry:

Create line.

Geometry -> Create -> Line 
Now insert in command line the coordinates of points to define the plate. Follow the order is very important. 
First point -> 0,0
Second point -> 100,0 
(Only it is necessary introduce points using two coordinates, the third coordinate Z is assume to 0 ). 
Press escape or middle button of mouse.

Assign property and material:

Define a new material.

Data -> Materials 

Click on the following icon to create a new material: 
Enter name for the new material  alum.
Fill all statements like in the picture:

And set density, in Others page, to 0.101

Click on the following icon to save the new material: 
2-Define and assign the property for the surface. 
Data -> Properties -> Property 

If you don't close material window is possible get the property window clicking on the following icon 
and select option "property" in the menu. 
Select from the top combo boxes the property . "beam"

Click on the following icon to create a new property: 
Enter name for the new property . cantilever
Fill all statements like in the picture:
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1.  
2.  
3.  

1.  

You have to select the previously created material in Composition Material.

Click on the following icon to save the new property: 
Now click on Assign button, select the line. 
To make a proof if the property is well assigned click on  button, select  option. Draw This property
Now in the NASTRAN Interface program window has to be an image like this:

Define Local Axes

The model has been created related to a global axes system XYZ that is unique for the entire problem. But every beam must have its own 
local axes system X’Y’Z’ in order to:

Refer section properties like  or  and  to this system.Inertia modulus thickness height
Some of the loads (that have the prefix ) are related also to this system.Local
Strength results over the beam are referred to this local axes system.

The main property of this system is that the local X’ axe must have the same direction than the beam.

The ways for defining local axes systems are:

Default. The program assigns a different local axes system to every beam with the following criteria:

X’ axe has the direction of the beam.
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If X’ axe has the same direction than global Z axe, Y’ axe has the same direction than global X. If not, Y’ axe is calculated so as to 
be horizontal (orthogonal to X’ and Z).
Z’ axe is the cross product of X’ axe and Y’ axe. It will try to point to the same sense than global Z (dot product of Z and Z’ axes will 
be positive or zero).

Note: The intuitive idea is that vertical beams have the Y’ axe in the direction of global X. All the other beams have the Y’ axe horizontal and 
with the Z’ axe pointing up.

Automatic. Similar to the previous one but the local axes system is assigned automatically to the beam by GiD. The final orientation 
can be checked with the  option in the GiD Conditions window.Draw Local Axes
Automatic alt. Similar to the previous one but an alternative proposal of local axes is given. Typically, User should assign 
Automatic local axes and check them, after assigning, with the  option. If a different local axes system is desired, Draw local axes
normally rotated 90 degrees from the first one, then it is only necessary to assign again the same condition to the entities with the Au

 option selected.tomatic alt
User defined. User can created different named local axes systems with the GiD command: Data->Local axes->Define

and with the different methods that can be chosen there. The names of the defined local axes will be added to the menu where Local axes 
are chosen.

Assign Local Axes.

Data -> Properties -> Local Axes 
Set statement Local Axes to Automatic (An automatic local will defined for all lines selected). 
Select the line of the geometry.

Mesh the Geometry:

1-Create a mesh. 
Meshing -> Generate 
Now you are asked about the size of elements to be generate, leave default value (10) 

Click on OK button 
Appears a window with information about the mesh:

Num. of linear elements = 10
Num. of nodes = 11 
Click on  button. OK
Note: It is possible label mesh elements and nodes using this option:
-Press right button mouse to get the contextual menu.

 -Select option "Label" and choose "All".

Assign Constraints:

1- Assign prescribed displacements and rotation. 
Data-> Boundary Conditions -> Constraints 

Click on the following icon to set the condition over points: 

Show the labels of nodes using this option:
-Press right button mouse to get the contextual menu.
-Select option "Label" and choose "All in" and choose points. 
Now in the NASTRAN Interface program window has to be an image like this:
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Node 1
Check the following items:
X-Displacement
Y-Displacement
Z-Displacement
X-Rotation
Y-Rotation
Uncheck Z-Rotation.

Node 11

Check the following items:
Y-Displacement
Z-Displacement
X-Rotation
Y-Rotation 
Uncheck X-Displacement and Z-Rotation.

Rest of nodes (except node 1 and node 11)
Check the following items:
Z-Displacement
X-Rotation
Y-Rotation
Uncheck 
X-Displacement
Y-Displacement 
Z-Rotation. 
To make a proof if the constraints are well assigned click on  button, select  option. Draw "Colors"
Now in the NASTRAN Interface program window has to be a image like this:

Perform the Analysis:

Design Executive Control Section.

Data -> Problem Data -> Executive Control 
Select type of NASTRAN will be use in the analysis. 
Check MODES and leave all the other statements uncheck. 
Leave the rest of statements with the default values. 
Click on  button. Accept data
2 - Design Case Control Section. 
Data -> Problem Data -> Case Control 
2.1.- Input data 
Leave all statements with default values. 
2.2.- Output data 
Set Title to  "Modes_Analysis"
Leave Subtitle, Label … and Post process with default values. 
Check Displacements uncheck the rest of output requests. 
In Output Design section leave the default values. 
Note: If the user wants to post processing the results of the analysis with MI/NASTRAN Interface is mandatory that the output device has to 

 set to PUNCH.
Click on  button. Accept data
3- Design Modes Extraction. 
Data -> Problem Data -> Dynamics 
In modes analysis tab: 
Set the following values to the different statements: 
-Method of eigenvalues extraction = GIV.
-First Frequency = 0.0
-Last Frequency = 350.0
-Desired number = 3
-Check Mass orthogonality test option.
-Leave the default values for the rest of statements. 
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In Dynamic Design tab:
Set Mass formulation = Coupled 
Click on  buttonAccept data

Set PARAM values.

Data -> Problem Data -> PARAM 
In MI/NASTRAN tab set WTMASS to 0.00259
Leave the rest of statements with default values. 
Click on  button.Accept data

Obtain Input File for NASTRAN Code:

File -> Import/Export -> Write Calculation File 
Appears a window to select in which folder and the name for save the file. It is very important write extension of the file in

Post process:

Click on the following icon to enter in the post process: 

Import punch file:

1- Import the punch file (***.pch) obtained from NASTRAN.
File -> Import -> Import PUNCH 
Appears a window to select the punch file located in NASTRAN results folder. 
After importing process is finished close the window.

Import FEMAP ASCII neutral file:

Import the FEMAP ASCII file (***.neu) obtained from NE/NASTRAN.

File -> Import -> FEMAP file 
Appears a window to select the *.neu file located in NASTRAN results folder. 
After importing process is finished close the window. 
Note: To obtain a FEMAP ASCII file in NE/NASTRAN go to NASTRAN editor: 
Setup -> Default Analysis Options 
Selects RSLTFILETYPE and set to FEMAP ASCII in Output Control Directives 

Visualization of results:

Contour Fill.

View results -> Contour Fill 
Select "Displacements"

Contour Fill Y-Displacement mode 22665.1
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To change step of analysis use this menu sequence: 
View results -> Default Analysis/Step -> 1 
Select that step you want to see.

Deformation.

View results -> Deformation
Select displacements.

Deformation mode 1.84e6

Numerical results:

To see numerical results in nodes, click on the following icon 
Select in which nodes you want to see the current numerical results display in the screen.

Create an Animation:

Select which kind of results will be displayed
Open Animation Window.

Windows -> Animate

Click on Play button.

Modes of beam

It is necessary edit the results file ***.F06 located in results folder of NASTRAN. 
Here are the results with (MI/NASTRAN):

Modes no. EIGENVALUE CYCLIC FREQUENCY

1 2.266509E+04 2.396066E+01

2 3.627142E+05 9.585227E+01

3 1.837810E+06 2.157598E+02
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